RIP OSPF 虚链路 重分发 特殊区域 (项目)

在这里插入图片描述
R1

<R1>display current-configuration 
#
sysname R1
#
router id 1.1.1.1
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher $N@0RGEWJ%jKUGU-KkpBrKK#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 10.1.0.1 255.255.0.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255
#
ospf 1
 area 0.0.0.3
  network 1.1.1.1 0.0.0.0
  network 10.1.0.0 0.0.255.255
  stub
#
user-interface con 0
 idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R2

<R2>display current-configuration  
#
sysname R2
#
router id 2.2.2.2
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher $N@0RGEWJ%+/Y@:Y>Lw(HKM#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 10.1.0.2 255.255.0.0
#
interface GigabitEthernet0/0/1
 ip address 10.0.0.2 255.255.0.0
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
#
ospf 1
 area 0.0.0.1
  network 2.2.2.2 0.0.0.0
  network 10.0.0.0 0.0.255.255
  vlink-peer 3.3.3.3
 area 0.0.0.3
  network 10.1.0.0 0.0.255.255
  stub no-summary
#
user-interface con 0
 idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R3

<R3>display current-configuration 
#
sysname R3
#
router id 3.3.3.3
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher X%aFSet1=MjKUGU-KkpBVKH#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 10.0.0.3 255.255.0.0
#
interface GigabitEthernet0/0/1
 ip address 10.56.0.3 255.255.0.0
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255
#
interface LoopBack1
 ip address 100.100.100.100 255.255.255.255
#
ospf 1
 area 0.0.0.0
  network 3.3.3.3 0.0.0.0
  network 100.100.100.100 0.0.0.0
  network 10.56.0.0 0.0.255.255
 area 0.0.0.1
  network 10.0.0.0 0.0.255.255
  vlink-peer 2.2.2.2
#
user-interface con 0
 idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R4

<R4>display current-configuration 
#
sysname R4
#
router id 4.4.4.4
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher Ptp5@TJ\&<ajUn1vMEIB:KG#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 10.56.0.4 255.255.0.0
#
interface GigabitEthernet0/0/1
 ip address 10.2.0.4 255.255.0.0
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0
 ip address 4.4.4.4 255.255.255.255
#
ospf 1
 area 0.0.0.0
  network 4.4.4.4 0.0.0.0
  network 10.56.0.0 0.0.255.255
 area 0.0.0.2
  network 10.2.0.0 0.0.255.255
  nssa no-summary
#
rip 1
#
user-interface con 0
 idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R5

<R5>display current-configuration 
#
sysname R5
#
router id 5.5.5.5
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher *n8z6YZ'C<jKUGU-KkpBXKK#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 10.2.0.5 255.255.0.0
#
interface GigabitEthernet0/0/1
 ip address 172.16.24.5 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0
 ip address 5.5.5.5 255.255.255.255
#
ospf 1
 import-route rip 1 cost 100
 area 0.0.0.2
  network 5.5.5.5 0.0.0.0
  network 10.2.0.0 0.0.255.255
  nssa
#
rip 1
 default-route originate
 network 172.16.0.0
 import-route ospf 1 cost 0
#
user-interface con 0
 idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
return

R6

<R6>display current-configuration 
#
sysname R6
#
router id 6.6.6.6
#
aaa
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default
 domain default_admin
 local-user admin password cipher uKA\B'(~)(3IF$':[285{KI#
 local-user admin service-type http
#
firewall zone Local
 priority 16
#
interface Ethernet0/0/0
#
interface Ethernet0/0/1
#
interface Serial0/0/0
 link-protocol ppp
#
interface Serial0/0/1
 link-protocol ppp
#
interface Serial0/0/2
 link-protocol ppp
#
interface Serial0/0/3
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 172.16.24.6 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface GigabitEthernet0/0/3
#
wlan
#
interface NULL0
#
interface LoopBack0
 ip address 6.6.6.6 255.255.255.255
#
rip 1
 network 6.0.0.0
 network 172.16.0.0
#
user-interface con 0
 idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
return
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值