1074 Reversing Linked List (25 分) java 题解

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N(≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

解题思路:

题目大意为给定一个链表,将链表上的每n个元素反转。(部分反转),并输出最终链表。

读取所给链表后,按顺序装入list中,求出需要反转的次数(要用list.size()求,有无效结点),利用双层for处理反转,外层控制次数,内层将每轮的处理元素装入list2中,用list.remove()方便,再将list中的剩余元素装入list2,最后处理结点间关系。

      //  处理结点间关系

        temp = -1;
        for(int i = list2.size() - 1;i >= 0;i--) {
            list2.get(i).next = temp;
            temp = list2.get(i).adress;;
        }

java代码(超时):

import java.io.*;
import java.util.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String[] split = br.readLine().split(" ");
		int adressStart = Integer.parseInt(split[0]);
		int n = Integer.parseInt(split[1]);
		int before = Integer.parseInt(split[2]);
		Node1074 arr[] = new Node1074[100005];
		for(int i = 0; i < n;i++) {
			split = br.readLine().split(" ");
			int adress = Integer.parseInt(split[0]);
			int data = Integer.parseInt(split[1]);
			int next = Integer.parseInt(split[2]);
			arr[adress] = new Node1074(adress, data, next);
		}
		
		int temp = adressStart;
		List<Node1074> list = new ArrayList<Node1074>();
		while(temp != -1) {//按链表顺序存入list中
			list.add(arr[temp]);
			temp = arr[temp].next;
		}
		int count = list.size() / before;//求需要反转几次
		
		List<Node1074> list2 = new ArrayList<Node1074>();
		for(int j = 1; j <= count ;j++) {//反转次数
			for(int i = before * j - 1;i >= before*(j - 1) ;i--) {
				list2.add(list.get(i));
			}
			
		}
		for(int i = before * count; i < list.size();i++) {//将剩余元素加入list2中
			list2.add(list.get(i));
		}
		
		temp = -1;
		for(int i = list2.size() - 1;i >= 0;i--) {//调整地址
			list2.get(i).next = temp;
			temp = list2.get(i).adress;;
		}
		for(Node1074 data : list2) {//输出
			System.out.println(data);
		}
	}
}
class Node1074{
	int adress;
	int data;
	int next;
	
	public Node1074(int adress, int data, int next) {
		this.adress = adress;
		this.data = data;
		this.next = next;
	}

	@Override
	public String toString() {
		if(this.next != -1)
			return String.format("%05d", adress) + " " + data + " " + String.format("%05d", next);
		else
			return String.format("%05d", adress) + " " + data + " " + String.format("%02d", next);
	}
}

PAT提交截图:

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值