1078 Hashing (25 分) java 题解

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

 

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

:Quadratic probing (with positive increments only) 译为:二次探测(只有正增量)  

解题思路:

题目大意:给定一串数,求他们在哈希表中的索引位置。

求最小素数,构造数组标志某一位置是否存在元素,当有冲突时,要二次正向探测解决,注意增量序列的取值和要在冲突上增加序列。

输出时,先用字符串拼接,最后直接输出,避免超时。

必备知识:

哈希表解决冲突:开放地址法,其中的二次探测:

Hi=(Hash(key)±di) mod m ,( 1≤  i < m )  要在冲突的基础上加增量!!

其中:Hash(key)为哈希函数

      m为哈希表长度

      di为增量序列 1^{2},-1^{2}2^{2} ,-2^{2} ,…(正向则去掉负值)

java代码:

import java.io.*;
import java.util.*;

public class Main {
	@SuppressWarnings({ "unchecked", "rawtypes" })
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String[] split = br.readLine().split(" ");
		int sizee = Integer.parseInt(split[0]);
		int n = Integer.parseInt(split[1]);
		int size = adjustToPrime(sizee);
		split = br.readLine().split(" ");
		List<Integer> list = new ArrayList<Integer>();
		for(int i = 0; i < split.length;i++) {
			list.add(Integer.parseInt(split[i]));
		}
		boolean []flag = new boolean[size];//动态开辟所需数组
		List list2 = new ArrayList();
		for(int i = 0;i < list.size();i++) {
			int temp = list.get(i) % size;
			if(!flag[temp]) {
				list2.add(temp);
				flag[temp] = true;
				continue;
			} else {//需要处理冲突
				int j = 1;
				while (j < size) {//j的范围为[1,size)
					temp = (list.get(i) + j * j) % size;//每次处理都是从冲突地址往后移,不可叠加
					if (!flag[temp]) {
						list2.add(temp);
						flag[temp] = true;
						break;
					}
					j++;
				}
				if (j >= size) {
					list2.add("-");
				}
			}
		}
		StringBuilder builder = new StringBuilder();
		for(int i = 0; i < list2.size();i++) {
			builder.append(list2.get(i) + " ");//拼接
		}
		System.out.println(builder.toString().trim());
	}
	public static int adjustToPrime(int num){//调整成为素数
		if(num == 1)//特判
			return 2;
		boolean flag = true;
		for(int i = 2;i <= Math.sqrt(num);i++) {
			if(num % i == 0) {
				flag = false;//需要调整
				break;
			}
		}
		if(!flag) {
			for(int i = num + 1;;i++) {
				int j;
				for(j = 2; j < (int)Math.sqrt(i) + 1;j++) {
					if(i % j == 0)break;
				}
				if(j == (int)Math.sqrt(i) + 1)
					return i;
			}
		}else {
			return num;//本身就是素数
		}
	}
}

PTA提交截图:

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值