1125 Chain the Ropes (25 分)

1125 Chain the Ropes (25 分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10^​4​​ ). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10^4​​ .

Output Specification:
For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15

Sample Output:
14

题目大意:
给定一组绳子,你需要把它们串成一根绳。每次串联时需要把两端绳子对折。求可以串成的绳子的最大长度

算法分析:
不难发现,越早加入的的绳子对折的次数越多。所以要形成最长的绳子,要把长的绳子晚一些加入。这里我用了sort进行从小到大排序,注意只有一根绳子时直接输出。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int num;
	cin>>num;
	int n[num];
	for(int i=0;i<num;i++)
	scanf("%d",&n[i]);
	if(num==1){
		printf("%d",n[0]);
		return 0;
	}
	sort(n,n+num);
	double sum=(n[0]+n[1])/2;
	for(int i=2;i<num;i++){
		sum=(sum+n[i])/2;
	}
	printf("%d",(int)sum);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值