配置如下:
第一步配置各个接口ip地址
R1:
R2:
R3:
R4:
R5:
R6:
第二步,除了R4各路由器配置去往R4的缺省路由
[R1]ip route-static 0.0.0.0 14.1.1.4
[R2]ip route-static 0.0.0.0 0 24.1.1.4
[R3]ip route-static 0.0.0.0 0 34.1.1.4
[R5]ip route-static 0.0.0.0 0 54.1.1.4
[R6]ip route-static 0.0.0.0 0 64.1.1.4
第三步,配置NAT地址转化
[R1]acl 2000
[R1-acl-basic-2000]rule 1 permit source any
[R1-GigabitEthernet0/0/1]nat outbound 2000
[R1-GigabitEthernet0/0/2]nat outbound 2000
[R2]acl 2000
[R2-acl-basic-2000]rule 1 permit source any
[R2-GigabitEthernet0/0/1]nat outbound 2000
[R3]acl 2000
[R3-acl-basic-2000]rule 1 permit source any
[R3-GigabitEthernet0/0/1]nat outbound 2000
[R5]acl 2000
[R5-acl-basic-2000]rule 1 permit source any
[R5-GigabitEthernet0/0/1]nat outbound 2000
[R6]acl 2000
[R6-acl-basic-2000]rule 1 permit source any
[R6-GigabitEthernet0/0/1]nat outbound 2000
第四步,配置星型结构的MGRE网络
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]source 41.1.1.1
[R1-Tunnel0/0/0]nhrp entry multicast dynamic
[R1-Tunnel0/0/0]nhrp network-id 100
[R2]interface Tunnel 0/0/0
[R2-Tunnel0/0/0]ip address 10.1.1.2 24
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp
[R2-Tunnel0/0/0]source g0/0/1
[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 41.1.1.1 register
[R2-Tunnel0/0/0]nhrp network-id 100
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.3 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source g0/0/1
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 41.1.1.1 register
[R3-Tunnel0/0/0]nhrp network-id 100
第五步,配置全连网状的MGRE网络
[R1]interface Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 10.1.2.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre p2mp
[R1-Tunnel0/0/1]source 14.1.1.1
[R1-Tunnel0/0/1]nhrp entry multicast dynamic
[R1-Tunnel0/0/1]nhrp network-id 101
[R1-Tunnel0/0/1]nhrp entry 10.1.2.2 54.1.1.5 register
[R5]interface Tunnel 0/0/1
[R5-Tunnel0/0/1]ip address 10.1.2.2 24
[R5-Tunnel0/0/1]tunnel-protocol gre p2mp
[R5-Tunnel0/0/1]source 54.1.1.5
[R5-Tunnel0/0/1]nhrp entry multicast dynamic
[R5-Tunnel0/0/1]nhrp network-id 101
[R5-Tunnel0/0/1]nhrp entry 10.1.2.1 14.1.1.1 register
[R6]interface Tunnel 0/0/1
[R6-Tunnel0/0/1]ip address 10.1.2.3 24
[R6-Tunnel0/0/1]tunnel-protocol gre p2mp
[R6-Tunnel0/0/1]source g0/0/1
[R6-Tunnel0/0/1]nhrp entry 10.1.2.1 14.1.1.1 register
[R6-Tunnel0/0/1]nhrp entry 10.1.2.2 54.1.1.5 register
[R6-Tunnel0/0/1]nhrp network-id 101
第六步,配置OSPF
[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]area 0
[R3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
[R3-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[R5]ospf 1 router-id 5.5.5.5
[R5-ospf-1]area 0
[R5-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]network 192.168.4.0 0.0.0.255
[R6]ospf 1 router-id 6.6.6.6
[R6-ospf-1]area 0
[R6-ospf-1-area-0.0.0.0]network 10.1.2.0 0.0.0.255
[R6-ospf-1-area-0.0.0.0]network 192.168.5.0 0.0.0.255
第七步,修改ospf 连接类型
[R1-Tunnel0/0/0]ospf network-type broadcast
[R2-Tunnel0/0/0]ospf network-type broadcast
[R3-Tunnel0/0/0]ospf network-type broadcast
[R1-Tunnel0/0/1]ospf network-type broadcast
[R5-Tunnel0/0/1]ospf network-type broadcast
[R6-Tunnel0/0/1]ospf network-type broadcast
adcast
[R1-Tunnel0/0/1]ospf network-type broadcast
[R5-Tunnel0/0/1]ospf network-type broadcast
[R6-Tunnel0/0/1]ospf network-type broadcast
## 第八步,验证