背包入门

01背包
Bone Collector(HDOJ2602)
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

这是一道01背包的典序题
我们定义一个二维数组dp[ i ][ j ] i表示前i个骨骼,j表示背包容量为j;
用0-1背包的问题来求解,就是要得到每一步的最优解,此时第i个物品面临选择,首先我们要看容量是否大于它的重量,
即 j > w[ i ]
如果大于,我们可以选择拿或不拿
1:拿,那么就必须要占用当前背包的空间。即用当前背包总容量 减去这块骨骼的体积即j - tj[ i ],再占用1个物品空间,所以i-1,此时的总价值就是dp [ i-1 ] [ j-tj[ i ] ] 的解 + 当前的价值jz[ i ] ,得到的就是放入当前物品得到的最优解。
2:不拿,那么就还是上一步的解,dp[ i-1 ][ j ]
下面是AC的代码

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int tj[1008],jz[1008],dp[1008][1008];
int main(){
	int t,n,v;
	scanf("%d",&t);
	while(t--){
		memset(dp,0,sizeof(dp));
		scanf("%d%d",&n,&v);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&jz[i]);
		}
		for(int i=1;i<=n;i++){
			scanf("%d",&tj[i]);
		}
		for(int i=1;i<=n;i++){
			for(int j=0;j<=v;j++){
				if(j<tj[i]){
					dp[i][j]=dp[i-1][j];
				}
				else dp[i][j]=max(dp[i-1][j],dp[i-1][j-tj[i]]+jz[i]);
			}
		}
	
		printf("%d\n",dp[n][v]);
		
	}
} 

完全背包
湫湫系列故事——减肥记I(HDOJ4508)
  对于吃货来说,过年最幸福的事就是吃了,没有之一!
  但是对于女生来说,卡路里(热量)是天敌啊!
  资深美女湫湫深谙“胖来如山倒,胖去如抽丝”的道理,所以她希望你能帮忙制定一个食谱,能使她吃得开心的同时,不会制造太多的天敌。

当然,为了方便你制作食谱,湫湫给了你每日食物清单,上面描述了当天她想吃的每种食物能带给她的幸福程度,以及会增加的卡路里量。
Input
  输入包含多组测试用例。
  每组数据以一个整数n开始,表示每天的食物清单有n种食物。
  接下来n行,每行两个整数a和b,其中a表示这种食物可以带给湫湫的幸福值(数值越大,越幸福),b表示湫湫吃这种食物会吸收的卡路里量。
  最后是一个整数m,表示湫湫一天吸收的卡路里不能超过m。

[Technical Specification]
  1. 1 <= n <= 100
  2. 0 <= a,b <= 100000
  3. 1 <= m <= 100000
Output
  对每份清单,输出一个整数,即满足卡路里吸收量的同时,湫湫可获得的最大幸福值。
Sample Input
3
3 3
7 7
9 9
10
5
1 1
5 3
10 3
6 8
7 5
6
Sample Output
10
20
这是一道完全背包的题,完全背包与01背包的差别就在于每一种可以多次取用,体现在代码中就是状态转移方程变成了dp[j]=max(dp[j],dp[j-k[i]]+x[i])
下面是AC的代码

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main(){
	int t,n,m,p,x[1008],k[1008];
	int dp[100008];
	while(scanf("%d",&n)!=EOF){
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){
			scanf("%d%d",&x[i],&k[i]);
		}
		scanf("%d",&m);
		for(int i=1;i<=n;i++){
			for(int j=k[i];j<=m;j++){
				dp[j]=max(dp[j],dp[j-k[i]]+x[i]);
			
			}
	}
		printf("%d\n",dp[m]);
	}
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值