本题要求实现一个函数,按输入数据的逆序建立一个链表。
函数接口定义:
struct ListNode *createlist();
函数 createlist 利用 scanf 从输入中获取一系列正整数,当读到 −1 时表示输入结束。按输入数据的逆序建立一个链表,并返回链表头指针。链表节点结构定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
int main()
{
struct ListNode *p, *head = NULL;
head = createlist();
for ( p = head; p != NULL; p = p->next )
printf("%d ", p->data);
printf("\n");
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
1 2 3 4 5 6 7 -1
输出样例:
7 6 5 4 3 2 1
来源:
来源:PTA | 程序设计类实验辅助教学平台
链接:https://pintia.cn/problem-sets/13/exam/problems/603
提交:
题解:
/*
* 按输入数据的逆序建立一个链表
*/
struct ListNode *createlist() {
// 提前输入一个数,判断是否需要建立链表
int num;
scanf("%d", &num);
/*
* 如果输入的第一个数据不是 -1 则将其存入链表头节点中,
* 之后以头插法方式往链表中新增节点以实现【按输入数据的逆序建立一个链表】的目的
*/
struct ListNode *head = (struct ListNode *) malloc(sizeof(struct ListNode));
head->next = NULL;
if (num != -1) {
head->data = num;
} else {
free(head);
return NULL;
}
// 继续输入数据,不为 -1 就将其头插到头节点之前
scanf("%d", &num);
while (num != -1) {
struct ListNode *temp = (struct ListNode *) malloc(sizeof(struct ListNode));
temp->data = num;
// 将临时节点头插到头节点之前
temp->next = head;
// 更新头节点为刚刚新增的节点
head = temp;
scanf("%d", &num);
}
return head;
}