本题目要求编写程序统计一行字符中单词的个数。所谓 “单词” 是指连续不含空格的字符串,各单词之间用空格分隔,空格数可以是多个。
输入格式:
输入给出一行字符。
输出格式:
在一行中输出单词个数。
输入样例:
Let’s go to room 209.
输出样例:
5
来源:
来源:PTA | 程序设计类实验辅助教学平台
链接:https://pintia.cn/problem-sets/13/exam/problems/473
提交:
题解:
#include<stdio.h>
#include<string.h>
int main() {
char str[1000];
gets(str);
int count = 0;
for (int i = 0; i < strlen(str); i++) {
// 所谓 “单词” 是指连续不含空格的字符串,各单词之间用空格分隔
if (str[i] != ' ' && (str[i + 1] == ' ' || str[i + 1] == '\0')) {
count++;
}
}
printf("%d", count);
return 0;
}