本题要求编写程序,将一个给定的整数插到原本有序的整数序列中,使结果序列仍然有序。
输入格式:
输入在第一行先给出非负整数 N(<10);第二行给出 N 个从小到大排好顺序的整数;第三行给出一个整数 X。
输出格式:
在一行内输出将 X 插入后仍然从小到大有序的整数序列,每个数字后面有一个空格。
输入样例:
5
1 2 4 5 7
3
输出样例:
1 2 3 4 5 7
来源:
来源:PTA | 程序设计类实验辅助教学平台
链接:https://pintia.cn/problem-sets/13/exam/problems/499
提交:
题解:
#include<stdio.h>
int main(void) {
int N;
scanf("%d", &N);
int array[11];
for (int i = 0; i < N; i++) {
scanf("%d", &array[i]);
}
int X;
scanf("%d", &X);
// 记录 X 插入到 array 数组中的下标位置
int location = -1;
for (int i = 0; i < N; i++) {
if (array[i] >= X) {
location = i;
break;
}
}
// 未找到 X 的插入位置,将 X 插入到数组尾
if (location == -1) {
array[N] = X;
} else {
// 将 location 之后元素依次后移一个位置
for (int j = N; j >= location; j--) {
array[j] = array[j - 1];
}
// 将 X 插入到 location 位置上
array[location] = X;
}
for (int i = 0; i <= N; i++) {
printf("%d ", array[i]);
}
return 0;
}