本题要求编写程序,输入若干英文单词,对这些单词按长度从小到大排序后输出。如果长度相同,按照输入的顺序不变。
输入格式:
输入为若干英文单词,每行一个,以 # 作为输入结束标志。其中英文单词总数不超过 20 个,英文单词为长度小于 10 的仅由小写英文字母组成的字符串。
输出格式:
输出为排序后的结果,每个单词后面都额外输出一个空格。
输入样例:
blue
red
yellow
green
purple
输出样例:
red blue green yellow purple
来源:
来源:PTA | 程序设计类实验辅助教学平台
链接:https://pintia.cn/problem-sets/13/exam/problems/586
提交:
题解:
#include<stdio.h>
#include<string.h>
int main(void) {
// 英文单词总数不超过 20 个,单词长度小于 10
char words[20][10];
int countWords = 0;
// 输入单词
while (scanf("%s", words[countWords]) == 1) {
if (strcmp("#", words[countWords]) == 0) {
break;
}
countWords++;
}
// 选择排序法,按单词长度从小到大排序
for (int i = 0; i < countWords; i++) {
for (int j = i + 1; j < countWords; j++) {
// 从剩下的 countWords - i 个单词中查找,若有单词长度比当前单词短,则交换它们
if (strlen(words[j]) < strlen(words[i])) {
char temp[10];
strcpy(temp, words[j]);
strcpy(words[j], words[i]);
strcpy(words[i], temp);
}
}
}
for (int i = 0; i < countWords; i++) {
printf("%s ", words[i]);
}
return 0;
}