1019 General Palindromic Number

题目来源:PAT (Advanced Level) Practice

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

 words:

General 普遍的,一般的         Palindromic Number 回文数        concept 概念,观念        

natural numbers 自然数        base 根基,基数        definition 定义

思路:

1. 本题的意思的是判断一个十进制数 n 在 b 进制系统中是否为回文数,并输出n 的 b进制形式;

2. 将 n 转化为 b 进制时采用 除 b 取余法,先得到的余数排在后边,并在相邻余数之间加空格,将转换后的结果以字符串形式保存并返回;

3. 通过两个指针 i 和 j 分别从字符串s的头和尾开始,判断 两处的数字是否相同;若全部相同则是回文数;当b>10时,进制中的1位数字可能在字串中占多个字符,因此对比前后指针处的数字时需要计算出两个相邻空格间的字符串的数值再进行判断;

//PAT ad 1019 General Palindromic Number
#include <iostream>
using namespace std;
#include <cmath>

string abc(int n,int b)		//将n转化为b进制数
{
	string s;
	while(n) 
	{
		int t=n%b;
		n/=b;
		s=to_string(t)+" "+s;
	}
	s.pop_back();   //舍掉最后一位 ,等同 s.erase(s.size()-1) 

	return s;
} 

bool test(string s,int b)		//检测s是否为回文数 Palindromic  Number
{
	int l=s.size(),i,j,k;
	
	for(i=0,j=l-1;i<=j;i++,j--)
	{
		int a=0,b=0;
		while(i<l&&s[i]!=' ')   //前 
		{
			a=a*10+s[i]-'0';
			i++;
		}
		
		for(k=0;j>=0&&s[j]!=' ';k++)		//后 
		{
			b=b+(s[j]-'0')*pow(10,k);
			j--;
		}

		if(a!=b)	return false;	
	} 
	return true;
} 

int main()
{
	int n,b;
	cin>>n>>b;		//输入 
	string s;
	s=abc(n,b);		//将n转化为b进制数 
	
	if(test(s,b))	cout<<"Yes"<<endl;
	else	cout<<"No"<<endl;
	
	cout<<s<<endl;   //输出 
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这段代码也可以实现在一个区间内寻找回文数并计算它们的和。 其中 `isPalindromic` 函数用于判断一个数是否为回文数,`getInputs` 函数用于获取区间的上边界和下边界,并检查用户的输入是否合法。在主程序中,我们首先调用 `getInputs` 函数获取区间的上边界和下边界,然后通过循环遍历这个区间,找到其中所有回文数,并将它们存储在一个列表中。最后,我们计算这些回文数的总和,并输出结果。 这段代码的工作流程与之前的示例代码基本相同,唯一的区别是在输入区间时,代码将上边界和下边界分别存储在 `upper` 和 `lower` 变量中,并检查它们的大小关系。如果用户输入的上边界比下边界小,则交换它们的值,以确保下边界始终小于或等于上边界。 下面是这段代码的完整实现: ```python def isPalindromic(n): s = str(n) return s == s[::-1] def getInputs(): count = 0 while count < 3: try: upper = int(input("请输入区间的上边界:")) lower = int(input("请输入区间的下边界:")) if upper > lower: upper, lower = lower, upper return upper, lower except: print("输入有误,请重新输入!") count += 1 print("输入错误次数过多,程序退出!") exit() palindromic_list = [] upper, lower = getInputs() for i in range(lower, upper + 1): if isPalindromic(i): palindromic_list.append(i) total = sum(palindromic_list) print("区间[{},{}]中的回文数为:{}".format(lower, upper, palindromic_list)) print("它们的和为:{}".format(total)) ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值