1024 Palindromic Number

题目来源:PAT (Advanced Level) Practice

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

words:

Palindromic 回文        via 通过,经过        reverse 颠倒,反转        initial 最初的,初始的

题意:

给定一个数n,将n经过k步操作将其变为回文数;在n不是回文数时将n反转与原来的n相加得到新的n认为是一步操作,直到n为回文数或者已经操作了k步为止;

思路:

1.  由于n比较大,而且要经过最多100步运算,所以选择以字符串s的形式保存n;(用long long保存n来作计算会有一个测试点过不了)

2. 在s不是回文数的情况下对s在k步以内进行操作(将s与s的反序相加得到新的s);

3. 输出回文数s和操作的步数,或者输出k步时的s和k;

//PAT ad 1024 Palindromic Number
#include <iostream>
using namespace std;
#include <algorithm>


bool PalindromicNumber(string s)	//判断s是否为回文数 
{
	int i=0,j=s.size()-1;
	for(;i<=j;i++,j--)
		if(s[i]!=s[j])
			return false;
	return true;
}

string ReverseNum(string s)	//求s的反序数 
{
	reverse(s.begin(),s.end());	
	while(s.front()=='0'&&s.size()>1)
		s.erase(0,1);
	return s;	
}

string Add(string s1,string s2)		//将两个字符串数s1和s2相加 
{
	int i=s1.size()-1;
	int j=s2.size()-1;
	string ans;
	int t,y=0;
	for(;i>=0&&j>=0;i--,j--)
	{
		t=s1[i]-'0'+s2[j]-'0';
		ans=to_string((t+y)%10)+ans;
		y=(t+y)/10;
	}
	
	for(;i>=0;i--)
	{
		t=s1[i]-'0';
		ans=to_string((t+y)%10)+ans;
		y=(t+y)/10;
	}
	for(;j>=0;j--)
	{
		t=s2[i]-'0';
		ans=to_string((t+y)%10)+ans;
		y=(t+y)/10;
	}
	if(y>0)
		ans=to_string(y)+ans;
	return ans;
}


int main()
{
	string s;
	int k;
	cin>>s>>k;
	
	int step=0;
	while(!PalindromicNumber(s)&&step<k)
	{
		s=Add(s,ReverseNum(s));
		step++;
	}
	
	cout<<s<<endl;
	cout<<step<<endl;
	
	
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值