1120 Friend Numbers

题目来源:PAT (Advanced Level) Practice

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10​4​​.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

word: 

among 在...之间        the number of 数量       

题意: 

在给定的n个数中,求他们的friend ID个数,并输出friend ID;friend ID就是一个数的各个数字之和;

思路:

1. 设置一个集合se用于存放friend ID;

2. 每输入一个数x,通过abc()函数求其各位数字和,即friend ID,并插入集合se中;

3. 输出集合se的元素个数和集合中的每一个元素;

//PAT ad 1120 Friend Numbers
#include <iostream>
using namespace std;
#include <set> 


int abc(int n)	//求n的每位的数字和 
{
	int sum=0;
	while(n)
	{
		sum+=n%10;
		n/=10;
	}
	return sum;
}
int main()
{
	int n;
	cin>>n;
	set<int> se; 	//保存friend id 
	while(n--)
	{
		int x;
		cin>>x;
		int id=abc(x);
		se.insert(id);	//将id插入集合 
	}
	
	string ans;

	for(auto w:se)	//遍历集合 
		ans+=to_string(w)+" ";	//记录friend id 

	ans.pop_back();	//舍掉末尾空格 
	cout<<se.size()<<endl;		//id 数量 
	cout<<ans<<endl;
	
	
	
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值