1046 Shortest Distance

题目来源:PAT (Advanced Level) Practice

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

words:

highway 公路        pair 一对        numbered 编号        guaranteed 担保,保证        round 环形的

题意:

给出由n个点构成的环的相邻点之间的距离,求任意两个点之间的距离;

思路:

1. 使用数组a[]存储相邻点之间的距离,a[i]表示 i 与 i+1之间的距离;

2. 使用数组cul[]存储累计距离,cul[i]表示 1 到 i+1 的距离和,cul[i-1]表示 1 到 i 的距离和;

3. 使用total表示所有相邻点距离的和,即整个cycle的长度;

4. 任意两点的距离由两种可能性,一种是顺时针距离d1=cul[a-1]-cul[b-1](a>b),另一种是逆时针距离d2=total-d1,选取两者中的最小者即为最短距离;

 

//PAT ad 1046 Shortest Distance
#include <iostream>
using namespace std;


int main()
{
	int n,m;
	cin>>n;
	
	int total=0;		//求所有路段的和,即整个cycle的和 
	int a[n+1]={0};		//存储相邻点的距离,a[i]表示 i与 i+1 的距离 
	int cul[n+1]={0};	//累计距离,cul[i]表示 1 到 i+1 的距离和,cul[i-1]表示 1 到 i 的距离和;	
	for(int i=1;i<=n;i++)
	{
		cin>>a[i];
		total+=a[i];
		cul[i]=a[i]+cul[i-1];
	}
	
	cin>>m;
	while(m--)
	{
		int a,b;
		cin>>a>>b;
		if(a<b)	swap(a,b);
		
		int d1=cul[a-1]-cul[b-1];		//顺时针距离 
		int d2=total-d1;				//逆时针距离 

		cout<<min(d1,d2)<<endl;			//最短距离 
	}

	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks. Input Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Inputcopy Outputcopy 25 5 2 2 14 11 21 17 4 Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
最新发布
07-24

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值