1074 Reversing Linked List

题目来源:PAT (Advanced Level) Practice

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

words:

constant 常数,不变的        reverse 反转,颠倒        

题意:

给定n个结点和链表的起始位置,将这个链表每k个结点做一次反转,输出做完反转后的链表;

思路:

1. 使用数组v[]存放所有的结点,其中v[]的下标表示结点的地址;

2. 从链表的起始地址开始遍历链表中所有的结点,并将遍历到的结点存放到数组ans[]中;

3. 将ans[]中的每k个结点使用reverse函数进行反转,最后不够k个结点不反转;

4. 依照输入的格式输出ans[]中的结点;

//PAT ad 1074 Reversing Linked List
#include <iostream>
using namespace std;
#include <algorithm>
#include <iomanip>
#include <vector>
#define N 100005

struct link			//结点 
{
	int address;
	int key;
	int next; 
};

int main()
{
	int start,n,k,i;
	cin>>start>>n>>k;
	
	vector<link> v(N);      //存放所有结点
	int address,key,next;
	for(i=0;i<n;i++)					//输入 
	{
		cin>>address>>key>>next;
		v[address].address=address;
		v[address].key=key;
		v[address].next=next;
	}
	
	vector<link> ans;
	for(i=0;start!=-1;i++)			//遍历链表,将链表中的结点放入到数组ans中 
	{
		ans.push_back(v[start]);
		start=v[start].next;
	}
	n=i;
	
	for(i=0;i<n;i+=k)			//每k个元素进行反转 
		if(i+k<=n)
			reverse(ans.begin()+i,ans.begin()+i+k);
	
	for(i=0;i<ans.size();i++)	//输出 
	{
		if(i!=0)
			cout<<setw(5)<<setfill('0')<<ans[i].address<<endl;
		cout<<setw(5)<<setfill('0')<<ans[i].address<<" "<<ans[i].key<<" ";
	}
    cout<<"-1"<<endl;
	
	
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值