Problem H: 找出出现次数最多的字母

Problem H: 找出出现次数最多的字母

Description

找出出现次数最多的字母

Input

多组测试,现在给你一行密文,全部由小写字母组成(不超过100个),你要找出出现次数最多的那个字母

Output

每组输出1行,输出出现次数最多的那个字母

Sample Input

aaaaaaabbc
nnnnnnnasnnnnasaaaa

Sample Output

a
n

直接看代码吧

#include <stdio.h>
#include <string.h>
int main()
{
    char a[200];
    while (gets(a) != NULL)
    {
        int cnt = 0;
        int b[200];
        int mmax = 0;
        int c[200] = {0};
        int len = strlen(a);
        for (int i = 0; i < len; i++)
        {
            b[i] = a[i];
        }
        for (int i = 0; i < len; i++)
            c[b[i]]++;

        for (int i = 97; i <= 123; i++)
        {
            if (c[i] != 0 && c[i] >= mmax)
            {
                mmax = c[i];
                cnt = i;
            }
        }
        printf("%c\n", cnt);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值