1009 Product of Polynomials (25 分)--PAT甲级

QuestionDescribe:
This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a N1 N2 a N2… NK a NK

where K is the number of nonzero terms in the polynomial, N
i and a Ni(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK<⋯<N2<N1≤1000.

Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
结尾无空行
Sample Output:
3 3 3.6 2 6.0 1 1.6
结尾无空行

题目分析:多项式相乘,比较简单

#include<iostream>
using namespace std;
double a1[1010];
double a2[1010];
double res[2010];
int main(){
    int k, n;
    double an;
    cin >> k;
    while(k --){
        cin >> n >> an;
        a1[n] += an;
    }
    cin >> k;
    while(k --){
        cin >> n >> an;
        a2[n] += an;
    }
    for(int i = 0; i <= 1000; i ++){
        for(int j = 0; j <= 1000; j ++){
            res[i + j] += a1[i] * a2[j];
        }
    }
    int cnt = 0;
    for(int i = 0; i <= 2000; i ++){
        if(res[i] != 0){
            cnt ++;
        }
    }
    cout << cnt ;
    for(int i = 2000; i >= 0; i --){
        if(res[i] != 0){
            printf(" %d %.1f",i, res[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值