1040 Longest Symmetric String (25 分)--PAT甲级(双指针)

QuestionDescribe:
Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
结尾无空行
Sample Output:
11
结尾无空行

题目解读:求字符串的最长公共回文序列的长度。

题目分析:想到了dp、双指针等算法,但只能写出来暴力算法,要看双指针的拖到最后。

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
	string str;
	getline(cin, str);
	int maxlen = 0;
	for(int i = 0; i < str.size(); i ++){
		for(int j = i; j < str.size(); j ++){
			string a1 = str.substr(i, j - i + 1);
			string a2 = a1;
			reverse(a1.begin(), a1.end());
			int len = a1.size();
			if(a1 == a2)
				maxlen = max(maxlen, len);
		}
	}
	cout << maxlen << endl;
	return 0;
}

ACwing大佬双指针做法

//双指针,往两边走,子串分奇偶
#include<iostream>
#include<cstring>

using namespace std;

int main()
{
    string str;
    getline(cin,str);

    int res=0;
    for(int i=0;i<str.size();i++)
    {
        int l=i-1,r=i+1;
        while(l>=0&&r<str.size()&&str[l]==str[r]) l--,r++;
        res=max(res,r-l-1);

        l=i,r=i+1;
        while(l>=0&&r<str.size()&&str[l]==str[r]) l--,r++;
        res=max(res,r-l-1);
    }
    cout<<res<<endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值