1091 Acute Stroke (30 分)--PAT甲级(三维dfs)

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M×N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

在这里插入图片描述

Figure 1

Output Specification:
For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
结尾无空行
Sample Output:
26
结尾无空行

题目分析:可以这么理解本题给出一个立体的每个底面状态,若为1,代表中风迹象,若累加起来大于等于t则已经中风。
具体解题是使用三维的dfs,在二维的基础上加以修改即可。

#include<iostream>
#include<queue>
using namespace std;
const int MAX_X = 1300;
const int MAX_Y = 130;
const int MAX_Z = 100;

int e[MAX_Z][MAX_X][MAX_Y];
bool visited[MAX_Z][MAX_X][MAX_Y];
int m, n, l, t;

struct node{
	int x, y, z;
};

int bfs(node v)
{
	int next[6][3] = {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
	queue<node> q;
	q.push(v);
	visited[v.x][v.y][v.z] = true;
	int cnt = 1;
	
	while(!q.empty()){
		auto w = q.front();q.pop();
		for(int i = 0; i < 6; i ++){
			int x = w.x + next[i][0], y = w.y + next[i][1], z = w.z + next[i][2];
			if(x >= 0 && x < l && y >= 0 && y < m && z >= 0 && z < n){
				if(!visited[x][y][z] && e[x][y][z]){
					visited[x][y][z] = true;					
					q.push({x, y, z});
					cnt ++;
				}
			}
		}
	}
	return cnt;
}

int main(){
	scanf("%d%d%d%d",&m,&n,&l,&t);
	for(int i = 0; i < l; i ++){
		for(int j = 0; j < m; j ++){
			for(int k = 0; k < n; k ++){
				scanf("%d", &e[i][j][k]);
			}
		} 
	} 
	int res = 0;
	for(int i = 0; i < l; i ++){
		for(int j = 0; j < m; j ++){
			for(int k = 0; k < n; k ++){
				if(!visited[i][j][k] && e[i][j][k]){
					int volume = bfs({i, j, k});
					if(volume >= t) res += volume;
				}
			}
		} 
	} 
	printf("%d\n",res);
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值