1155 Heap Paths (30 分)--PAT甲级(bfs思想)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50
结尾无空行
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
结尾无空行
Sample Input 2:
8
8 38 25 58 52 82 70 60
结尾无空行
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
结尾无空行
Sample Input 3:
8
10 28 15 12 34 9 8 56
结尾无空行
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap
结尾无空行

题目分析:题目的意思是从右往左依次输出二叉树的每一条路径,这里可以bfs的思想来做。

bfs的结束条件为i * 2 + 1 > n && i * 2 > n
循环条件为遍历右子树,遍历左子树。

注意:判断是大根堆还是小根堆的时候不能仅仅使用temp[1]>=temp[2]。
假如temp[1]==temp[2]的时候则会默认是大根堆,实则后面的数据可能是小根堆。

#include<iostream>
#include<vector>
using namespace std;

vector<int> v;
int n, flag = 0;//标记min/max/no 
vector<int> temp;
bool change = false;

//1. 存入数组
//2. 遍历所有堆路径
	//从右往左输出
	
	//递归:若有右子树,先存数至temp,进入右子树
	// 		若无右子树,先存数至temp,进入左子树
	
	//左右子树皆为空,则输出vector,并且清空,
	//其中需要判断vector 的顺序,判断minHeap,还是maxHeap还是 
void heaptree(int i){
	temp.push_back(v[i]);
	if(i * 2 + 1 > n && i * 2 > n){ 
		if(flag == 0){
			for(int j = 0; j < temp.size() - 1; j ++){
				if(temp[j] > temp[j + 1]){
					flag = 1;
				}else if(temp[j] < temp[j + 1]){
					flag = -1;
				}
			}
		}
//		flag = temp[1] >= temp[2] ? 1 : -1;//假设是大根堆/小根堆 假设有误,若等于难以判断 
		for(int j = 0; j < temp.size(); j ++){
			if(j != 0) { //验证假设 
				cout << ' ';
				if(temp[j - 1] >= temp[j] && flag == -1){
					change = true;
				}else if(temp[j - 1] <= temp[j] && flag == 1){
					change = true;
				}
			};
			cout << temp[j];
		}
		cout << endl;
		temp.pop_back();
		return;		
	}
	for(int j = 1; j >= 0; j --){
		if(i * 2 + j <= n){
			heaptree(i * 2 + j);
		}
	}
	temp.pop_back(); 
} 

int main(){
	scanf("%d", &n);
	v.reserve(n + 1);
	for(int i = 1; i <= n; i ++) scanf("%d", &v[i]);
	heaptree(1);
	if(change) puts("Not Heap");
	else if(flag == 1) puts("Max Heap");
	else if(flag == -1) puts("Min Heap");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值