1142 Maximal Clique (25 分)--PAT甲级(图)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
结尾无空行
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
结尾无空行

题目分析:给定一个无限图,接着给出一些测试点,判断是否这些点在图中是两两相连的,若不是:输出Not a Cilque ,若是,判断与这些点连通的点 ,能否够到这些所有的点,若能,Not Maximal,否则Yes 。

#include<iostream>
#include<vector>
using namespace std;
int e[210][210]; 
vector<int> g[210];
int main(){
	int nv, ne, m;
	scanf("%d%d", &nv,&ne);
	while(ne --){
		int a, b;
		scanf("%d%d", &a, &b);
		e[a][b] = e[b][a] = 1;
		g[a].push_back(b);
		g[b].push_back(a);
	}
	scanf("%d", &m);
	while(m --){
		int k;
		scanf("%d", &k);
		vector<int> arr(k);
		bool flag = true;
		bool flag0 = true;
		bool st[210] ={0};
		for(int i = 0; i < k; i ++){
			scanf("%d", &arr[i]);
			st[arr[i]] = true;
		}
		for(int i = 0; i < arr.size() && flag; i ++){
			for(int k = 0; k < arr.size(); k ++){
				if(i == k) continue;
				if(e[arr[i]][arr[k]] != 1){
					flag = false;
					break;
				}
			}
		}
		if(flag == false){
			puts("Not a Clique");
			flag0 = false;//标记上面有没有输出 
		}
		else{
			for(int i = 0; i < k && flag; i ++){
				for(int j = 0; j < g[arr[i]].size() && flag; j ++){
					if(st[g[arr[i]][j]] == false){
						bool flag1 = true;
						int extra = g[arr[i]][j];
						for(int p = 0; p < k; p ++){
							if(e[extra][arr[p]] != 1){
								flag1 = false;
								break;
							}
						}
						if(flag1 == true){
							flag = false;
							break;
						}
					}
				}
			}
		}
		if(flag0){
			if(flag) puts("Yes");
			else puts("Not Maximal");			
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值