实验10.3 删除单项链表偶数节点

【问题描述】输人若干个正整数(输入-1 为结束标志),并建立个单向链表,将其中的偶数值结点删除后输出。试编写相应程序。
【样例输入】

1 2 3 4 5 6 7 -1

【样例输出】

1 3 5 7

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct zhengshu{
    int n;
    struct zhengshu *next;
};
//新建链表
struct zhengshu *Creat(void);
//遍历链表
void Print(struct zhengshu *head);
//删除结点
struct zhengshu *Delete(struct zhengshu *head);

int main()
{
    struct zhengshu *head;
    
    head=Creat();
    head=Delete(head);
    Print(head);
}

//新建链表
struct zhengshu *Creat(void){
    struct zhengshu *head,*tail,*p;
    int num;
    int size=sizeof(struct zhengshu);
    
    head=tail=NULL;
    scanf("%d",&num);
    while (num!=-1) {
        p=(struct zhengshu*)malloc(size);
        p->n=num;
        p->next=NULL;
        if (head==NULL)
            head=p;
        
        else
           tail->next=p;
        tail=p;
       
        
        scanf("%d",&num);
    }
    return head;
}
//删除结点
struct zhengshu *Delete(struct zhengshu *head)
{
    struct zhengshu *p1 = NULL,*p;
    p1=head;
    for (p=head;p!=NULL;p=p->next){
        
      if ((p->n)%2==0) {
        if(p==head){
            head=p->next;
            free(p);}
        else{
        p1->next=p->next;
            free(p);}
    }
        else
            p1=p;
    }
    return head;
}



//遍历链表
void Print(struct zhengshu *head)
{
    struct zhengshu *ptr;
    ptr=head;
    while (ptr!=NULL) {
        printf("%d ",ptr->n);
        free(ptr);
        ptr=ptr->next;
    }
}


  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值