1001:
Description
Xiao_ming有两个哥哥,大哥叫Da_min,二哥叫Er_min。三兄弟放学回家,父母分别跟他们打招呼。
Input
无
Output
请输出: Hello Da_min, Hello Er_min, Hello Xiao_ming!
代码:
#include <stdio.h>
#include <stdlib.h>
int main()
{
printf(“Hello Da_min,\nHello Er_min,\nHello Xiao_ming!\n”);
return 0;
}
1002:
算术基本运算
Time Limit: 1 Sec Memory Limit: 2 MB
Description
计算两整数x和y(0<x,y<1000)的和、差、积、商、余数、x的平方和y的三次方。
Input
输入只有一行,格式见sample。
Output
输出为多行,按顺序每行输出x,y的和、差、积、商、余数、x的平方和y的三次方,格式见sample
Sample Input
x = 11, y = 3
Sample Output
x + y : 14
x - y : 8
x * y : 33
x / y quotient: 3, remainder: 2
x ^ 2 : 121
y ^ 3 : 27
HINT
注意输入输出格式。了解C语言整数除法运算符的特点,并且没有求幂的运算符。
代码:
#include <stdio.h>
int main()
{
int x,y;
scanf(“x = %d, y = %d”,&x,&y);
printf(“x + y : %d\nx - y : %d\n”,x+y,x-y );
printf(“x * y : %d\n”,xy);
printf(“x / y quotient: %d, remainder: %d\n”,x/y,x%y);
printf(“x ^ 2 : %d\n”,xx );
printf(“y ^ 3 : %d\n”,yyy );
return 0;
}