K - Rochambeau(并查集,枚举)

N children are playing Rochambeau (scissors-rock-cloth) game with you. One of them is the judge. The rest children are divided into three groups (it is possible that some group is empty). You don’t know who is the judge, or how the children are grouped. Then the children start playing Rochambeau game for M rounds. Each round two children are arbitrarily selected to play Rochambeau for one once, and you will be told the outcome while not knowing which gesture the children presented. It is known that the children in the same group would present the same gesture (hence, two children in the same group always get draw when playing) and different groups for different gestures. The judge would present gesture randomly each time, hence no one knows what gesture the judge would present. Can you guess who is the judge after after the game ends? If you can, after how many rounds can you find out the judge at the earliest?

Input
Input contains multiple test cases. Each test case starts with two integers N and M (1 ≤ N ≤ 500, 0 ≤ M ≤ 2,000) in one line, which are the number of children and the number of rounds. Following are M lines, each line contains two integers in [0, N) separated by one symbol. The two integers are the IDs of the two children selected to play Rochambeau for this round. The symbol may be “=”, “>” or “<”, referring to a draw, that first child wins and that second child wins respectively.

Output
There is only one line for each test case. If the judge can be found, print the ID of the judge, and the least number of rounds after which the judge can be uniquely determined. If the judge can not be found, or the outcomes of the M rounds of game are inconsistent, print the corresponding message.

Sample Input
3 3
0<1
1<2
2<0
3 5
0<1
0>1
1<2
1>2
0<2
4 4
0<1
0>1
2<3
2>3
1 0
Sample Output
Can not determine
Player 1 can be determined to be the judge after 4 lines
Impossible
Player 0 can be determined to be the judge after 0 lines
题意:
借鉴的大佬博客

#include <cstdio>
#include <cmath>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <map> 
#include <stack>
using namespace std;
using namespace std;
const int maxn=100006;
int pre[10005],rank[10005];
int n,m; 
struct node{
	int v,u,op;
}a[22222];
int find(int x)
{
	if(pre[x]==x)
	return x;
	
		int t=pre[x];
		pre[x]=find(t);
		rank[x]=(rank[x]+rank[t])%3;
		return pre[x];
	
}
void unit()
{
	for(int i=0;i<=n;i++)
	{
			pre[i]=i;
			rank[i]=0;//自己与自己是同类 
	}

}
bool judge(int v,int u,int op)
{
	int fx=find(v);
	int fy=find(u);
	if(fx==fy)
	{
		return ((rank[v]-op+3)%3!=rank[u]);
	}
	else
	{
		pre[fx]=fy;
		rank[fx]=(rank[u]+op-rank[v]+3)%3;
		return 0;
	}
}
int main()
{
	while(cin>>n>>m)
	{
		char c;
		
		for(int i=1;i<=m;i++)//从1开始,行数没有0 
		{
			cin>>a[i].v>>c>>a[i].u;
			if(c=='=')
			a[i].op=0;
			if(c=='>')
			a[i].op=2;
		    if(c=='<')
			a[i].op=1;
		}
		int line=0;//确定裁判时的下标 
		int num=0;//找到的裁判个数 
		int temp;//裁判的下标 
		for(int i=0;i<n;i++)
		{
			unit();
			int flag=1;
			for(int j=1;j<=m;j++)
			{
				int v=a[j].v,u=a[j].u,op=a[j].op;
				if(a[j].v==i||a[j].u==i)//枚举,假设是裁判 
				continue;
				if(judge(v,u,op))//出现矛盾,即假设不成立,i不是裁判。 
				{
					flag=0;
		            line=max(line,j);
		            break;
				}
			}
			if(flag)//假设成立。i是裁判 
			{
				
				temp=i;
				num++; 
			}
		}
		if(num==0)//没有裁判 
		{
			cout<<"Impossible"<<endl;
		}
		else if(num>1)//有多个裁判 
		cout<<"Can not determine"<<endl;
		else
		cout<<"Player "<<temp<<" can be determined to be the judge after "<<line<<" lines"<<endl;
	}
	return 0; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值