I - Constructing Roads(最小生成树)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179
题意:
给一个数字n表示村庄个数
接下来n*n的矩阵,map[i][j]表面从村庄i到村庄j的距离
下一行一个数字k
接下来k行,每行俩数字a,b,表明村庄a到村庄b之间已经修好了路,
求还要修得的最短路长。
我个憨憨,还一直在想他给了我两个村庄之间的距离,就表示不用再计算了(这样想是没毛病),但我却纠结于在遍历道路的时候怎样把已给的道路忽略,唉,看了别人的才发现可以就直接让道路为0,啊啊啊啊啊,多简单,我真的对自己无语死了!!!!!!

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=200,MAX=0x3f3f3f3f;
int n,m;
int from,to,w;
int dist[N],map[N][N];
bool biao[N];
int prim()
{
	memset(dist,0x3f,sizeof(dist));
	memset(biao,0,sizeof(biao));
	dist[1]=0,biao[1]=1;
	int t=1,sum=0;
	for(int i=0;i<n-1;i++)
	{
		for(int j=1;j<=n;j++)
		{
			dist[j]=min(dist[j],map[t][j]);
		}
		t=-1;
		for(int j=1;j<=n;j++)
		{
			if(!biao[j]&&(t==-1||dist[t]>dist[j]))
			t=j;
		}
		sum+=dist[t];
		biao[t]=1;
	}
	return sum;
}
int main()
{
	
  while(cin>>n)
  {
  		memset(map,0x3f,sizeof(map));
  		for(int i=1;i<=n;i++)
  		{
  			for(int j=1;j<=n;j++)
  			{
  				cin>>map[i][j];
			}
		  }
		  cin>>m;
  		while(m--)
  		{
  			int a,b;
  			cin>>a>>b;
  		map[a][b]=map[b][a]=0;

  			
		}
		int ans=prim();
		cout<<ans<<endl;
	
  }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值