二分图 - The Accomodation of Students - HDU - 2444

Problem Description

There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input

For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output

If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No
3

题意:将所有人分为两组且组内不能有相互认识的,若不能则输出No,若能则将朋友两两匹配,并求出匹配数
理解:利用染色法来判断是否能成功分组,再利用二分图最大匹配来分组

#include<bits/stdc++.h>
using namespace std;
#define N 210
int n,m,a,b,f,i,x;
int v[N],bk[N],match[N],e[N][N];
int bfs()
{
	memset(v,0,sizeof(v));
	queue<int>q;
	q.push(1);
	v[1]=1;
	while(!q.empty())
	{
		x=q.front();
		q.pop();
		for(i=1;i<=n;i++)
			if(e[x][i])
			{
				if(!v[i])
				{
					v[i]=-v[x];
					q.push(i);
				}
				else if(v[i]==v[x])
					return 0;
			}
	}
	return 1;
}
int cha(int x)
{
	for(int i=1;i<=n;i++)
		if(!bk[i]&&e[x][i])
		{
			bk[i]=1;
			if(!match[i]||cha(match[i]))
			{
				match[i]=x;
				return 1;
			}
		}
	return 0;
}
int dfs()
{
	int ans=0;
	memset(match,0,sizeof(match));
	for(i=1;i<=n;i++)
	{
		memset(bk,0,sizeof(bk));
		if(cha(i)) ans++;
	}
	return ans;
}
int main()
{
	
	while(cin>>n>>m)
	{
		memset(e,0,sizeof(e));
		for(i=0;i<m;i++)
		{
			cin>>a>>b;
			e[a][b]=1;
		}
		if(!bfs()) cout<<"No"<<endl;
		else cout<<dfs()<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值