四进制加法(运算符重载)

题目描述

定义一个四进制的类,重定义“+”号实现四进制数的累加。

输入

第一行输入所需要的四进制数的个数

第二行开始,依次输入四进制数

输出

所有输入四进制数累加的和

输入样例:

3
13
2
21

输出样例:

102

#include<iostream>
#include<cmath>
using namespace std;

class SJZ 
{
private:
	int m_num;
public:
	SJZ(int n = 0):m_num(n)
    {
    }
	void setN(int n)
	{
		m_num = n;
	}

	void print()
	{
		cout << m_num << endl;
	}

	SJZ operator+(SJZ& s)
	{
		int sum = m_num, i = 0, k;
		m_num += s.m_num;
		sum += s.m_num;

		while (sum != 0)
		{
			sum /= 10;
			i++;//十进制是几位数
		}

		for (int j = 0; j < i; j++)
		{
			k = pow(10, j);
			if ((m_num / k % 10) >= 4)
			{
				m_num += 6 * k;
			}
		}
		SJZ s2(m_num);
		return s2;
	}
};

int main()
{
	int t, n; 
	cin >> t;
	SJZ* s = new SJZ[t];
	SJZ s1;
  
	for(int i = 0; i < t; i++)
	{
		cin >> n;
		s[i].setN(n);
	}
  
	for (int i = 0; i < t; i++)
	{
		s1 = s1 + s[i];
	}
	s1.print();
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C++中,我们可以通过运算符重载定义定义加法和减法运算符。运算符重载是指在定义一个,使得该函可以在使用特定运算符时被调用。 以下是加法运算符重载的示例: ```cpp class Complex{ private: double real; double imag; public: Complex(double r = 0, double i = 0){ real = r; imag = i; } Complex operator+(const Complex& c){ Complex res(real + c.real, imag + c.imag); return res; } }; ``` 在上面的示例中,我们定义了一个名为Complex的,该具有两个属性:real和imag,表示复的实部和虚部。我们还定义了一个构造函和一个加法运算符重载加法运算符重载使用operator+作为函名,并使用const Complex&作为参。在函体中,我们创建了一个新的Complex对象,将其实部和虚部初始化为当前对象和传入对象的实部和虚部的和,然后将该对象返回。 下面是减法运算符重载的示例: ```cpp class Complex{ private: double real; double imag; public: Complex(double r = 0, double i = 0){ real = r; imag = i; } Complex operator-(const Complex& c){ Complex res(real - c.real, imag - c.imag); return res; } }; ``` 在上面的示例中,我们定义了一个名为Complex的,该具有两个属性:real和imag,表示复的实部和虚部。我们还定义了一个构造函和一个减法运算符重载。减法运算符重载使用operator-作为函名,并使用const Complex&作为参。在函体中,我们创建了一个新的Complex对象,将其实部和虚部初始化为当前对象和传入对象的实部和虚部的差,然后将该对象返回。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值