第二周--贪心题解(H)

题H:
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3

题意:一个对木头的加工厂,当长度和质量大于等于前面那跟加工的木头长度和质量时,是无需调整机器的,每次调整机器都需要1分钟。要求用最少的时间去完成对于一批木头的加工。

思路:
1.这里木头的长度和质量都是地位都是等价的,因为既要对长度进行排序,又对质量有要求。所以不妨将长度优先考虑,升序排列,然后长度若相等,则质量小的优先。(sort 或重载运算符两种方式)
2.此题最大难点,在于比较对象的判定,需要不断更新。所以定义结构中要再开一个变量标记,先使它初值为0,当被选取对象后(第一个选取的为a[0]),再标记为1,。利用for循环,遍历之后满足题目条件(质量长度都大于等于被选取对象时)的结构元素然后轨后一类标记为1。
3.注意细节。循环中定义变量k,使得内层循环中的比较对象可以不断刷新。外层for循环中如果碰到已被归类的数组元素,continue实现跳过。

#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstring>

using namespace std;
struct stick
{
    int x;
    int y;
    int f;
}a[5005];
bool cmp(stick a1,stick a2)
{
    if(a1.x==a2.x) return a1.y<a2.y;
    return a1.x<a2.x;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i].x>>a[i].y;
            a[i].f=0;
        }
        sort(a,a+n,cmp);
        int time=0;
        for(int i=0;i<n;i++)
        {
           int k;
           if(a[i].f==1) continue;
           a[i].f=1;
           time++;k=i;
           for(int j=i;j<n;j++)
           {
               if(a[j].f==0&&a[j].x>=a[k].x&&a[j].y>=a[k].y)
               {
                   a[j].f=1;
                   k=j;
               }
           }
        }
        cout<<time<<endl;
    }
    return 0;
}

总结:
难点1.需要对两个对象(长度和质量)实现排序。

难点2.非常难以想到的,自我感觉很重要的方法。利用双重for循环,和两个用来标记的变量,和continue的指令 来实现对数组的分类,加以筛选。

 for(int i=0;i<n;i++)
        {
           int k;
           if(a[i].f==1) continue;
           a[i].f=1;
           time++;k=i;
           for(int j=i;j<n;j++)
           {
               if(a[j].f==0&&a[j].x>=a[k].x&&a[j].y>=a[k].y)
               {
                   a[j].f=1;
                   k=j;
               }
           }
        }
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值