HDU - 1171 Big Event in HDU

Big Event in HDU

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output
20 10
40 40

思路:题目要求,两个学院的价值接近且前一个大于后一个,所以前一个的价值一定大于等于总价值的一半,后一个的价值一定小于等于总价值的的一半,所以以总价值的一半为界,计算在总价值一半的范围内,后一个价值的最大值,前一个就是总价值减去后一个价值。
注意:这道题我开始做的时候数组开的小了所以WA,后来看了别人的代码后才知道要开到50 *50 *100,还有就是这个题虽然说-1时结束,但是还是要加上!=EOF的,而且用n!=-1,是WA的,要用n<=0是跳出。

#include <stdio.h>
#include <math.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[250005],a[11000],b[11000],arr[11000]={0};
int main()
{
    int m,i,j;
    while(scanf("%d",&m)!=EOF)
    {
        if(m<=0)
        {
            break;
        }
        memset(dp,0,sizeof(dp));
        int sum=0,ans=0,t;
        j=1;
        for(i=1;i<=m;i++)
        {
            cin>>a[i]>>b[i];
            for(t=1;t<=b[i];t++)
            {
                arr[j]=a[i];
                ans=ans+a[i];
                j++;
            }
            sum=sum+b[i];
        }
        sort(arr+1,arr+sum+1);
        for(i=1;i<=sum;i++)
        {
            for(j=ans/2;j>=arr[i];j--)
            {
                dp[j]=max(dp[j],dp[j-arr[i]]+arr[i]);
            }
        }
        printf("%d %d\n",ans-dp[ans/2],dp[ans/2]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值