快速排序*******

已知快速排序的部分代码如下,勿改动,请补充实现快速排序函数:void QuickSort(int first,int end);   //quickSort  要求:输出每趟排序结果

#include<iostream>

using namespace std;

const int MaxSize=100;

class List

{

private:

int r[MaxSize+1];

int n;

public:

    List(){n=0;} //empty list

void InsertR(int k)  //表尾插入

{  r[++n]=k;}

void Display();      //display

void QuickSort(int first,int end);   //quickSort

void QuickSort()

{

QuickSort(1,n);

}

};

 

void List::Display()

{

for(int i=1;i<=n;i++)

       cout<<r[i]<<" ";  

cout<<"\n";

}

int main()

{

List L;

while(1)

{

int k;

cin>>k;

if(!k) break;

        L.InsertR(k);

}

//L.Display();

L.QuickSort();

//L.Display();

return 0;

}

Input

Output

Sample Input

12 21 32 2 4 24 21 432 23 9 0

Sample Output

9 4 2 12 32 24 21 432 23 21 
2 4 9 12 32 24 21 432 23 21 
2 4 9 12 32 24 21 432 23 21 
2 4 9 12 21 24 21 23 32 432 
2 4 9 12 21 24 21 23 32 432 
2 4 9 12 21 23 21 24 32 432 
2 4 9 12 21 21 23 24 32 432
//已知快速排序的部分代码如下,勿改动,请补充实现快速排序函数:void QuickSort(int first,int end);   //quickSort  要求:输出每趟排序结果
#include<iostream>
using namespace std;
const int MaxSize=100;
class List
{
private:
int r[MaxSize+1];
int n;
public:
    List(){n=0;} //empty list
void InsertR(int k)  //表尾插入
{  r[++n]=k;}
void Display();      //display
void QuickSort(int first,int end);   //quickSort
void QuickSort()
 
{
QuickSort(1,n);
}
int  partition(int first,int end);
};
int  List::partition(int first,int end)
{
 
   int temp;
   temp=r[first];
    while(first<end)
    {
        while(first<end&&r[end]>=temp)
            --end;
            r[first]=r[end];
        while(first<end&&r[first]<=temp)//i一直后移 知道找到比基准元素大的数才结束后移,这时候才会赋值
            ++first;
            r[end]=r[first];
    }
    r[first]=temp;
    Display();
    return first;
}
void List::Display()
{
for(int i=1;i<=n;i++)
       cout<<r[i]<<" ";
cout<<"\n";
}
void List::QuickSort(int first,int end)//quickSort
{
  if(first==end)
    return;
  else
    if(first<end)
  {
      int p=partition(first,end);
      QuickSort(first,p-1);
      QuickSort(p+1,end);
 
  }
 
}
int main()
{
List L;
while(1)
{
int k;
cin>>k;
if(!k) break;
        L.InsertR(k);
}
//L.Display();
L.QuickSort();
//L.Display();
return 0;
}
 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值