题解报告: Supermarket,Muddy roads 贪心

Muddy roads

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.
Input

  • Line 1: Two space-separated integers: N and L

  • Lines 2…N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.
    Output

  • Line 1: The miminum number of planks FJ needs to use.
    Sample Input
    3 3
    1 6
    13 17
    8 12
    Sample Output
    5

思路:贪心策略:先将区间按升序排列,从左往右开始铺木板,若某个区间不能正好铺满,则将多出来的一块与下一个区间左端点比较,并将最大值作为起始端点继续铺。注意:若某个区间已经被上一个木板覆盖则continue(这一点忽略了WA了好几次)。题目不难,主要锻炼代码能力。

AC代码:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
    int x,y;
    friend bool operator <(const node&a,const node&b){
        return a.x<b.x;
    }
}a[10005];
int main()
{
    int n,l,sum=0,t=0;

    cin>>n>>l;
    for(int i=1;i<=n;i++)cin>>a[i].x>>a[i].y;
    sort(a+1,a+1+n);

    for(int i=1;i<=n;i++){
        if(t>=a[i].y)continue;
        t=max(t,a[i].x);
        //cout<<t<<' ';
        sum+=(a[i].y-t)/l;

        if((a[i].y-t)%l){
            t=a[i].y+(l-(a[i].y-t)%l);
            sum++;
        }

        //cout<<sum<<endl;
    }
    cout<<sum;
}

Supermarket

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10
Sample Output
80
185

思路:贪心策略:将物品价值按升序排列,加上当前日期所售卖的物品,若当前日期已经有物品销售,则往前找空日期(刚开始题目理解错误,以为找每个日期的最大值),找空日期可以用循环,也可以用并查集

AC代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<map>
#define ll long long
using namespace std;
int n,flag[10005]={0};

struct node{
    int x,y;
    friend bool operator <(const node&a,const node&b){
        return a.x>b.x;
    }
}a[10005];

int f(int x){
    while(x!=flag[x]) x=flag[x];
    return x;
}

int main()
{
    while(cin>>n){
        for(int i=0;i<=10003;i++)flag[i]=i;
        int sum=0;

        for(int i=1;i<=n;i++) cin>>a[i].x>>a[i].y;

        sort(a+1,a+1+n);

        for(int i=1;i<=n;i++){
            int t=f(a[i].y);

            if(t){
                flag[t]=t-1;

                sum+=a[i].x;

            }
        }

        cout<<sum<<endl;

    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值