G - Best Cow Line (贪心)

7 篇文章 0 订阅

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single initial (‘A’…‘Z’) of the cow in the ith position in the original line

Output
The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’…‘Z’) in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output
ABCBCD

题目大意:
给出一个字符串,你只能从始端和末端取出字符,将它排列成字典序尽量小的一个新的字符串。

解题思路:
贪心思想,优先取字典序小的字符,若字符相同,则判断下一个,直到出现不同或遍历完剩余字符为止。这样便可以得到字典序最小的新字符串

完整代码:

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
	int n;
	char c;
	string s;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>c;
		s+=c;
	}
	int l=0,r=n-1,m=0;
	while(r>=l){
		int flag=0;
		while(r-flag>=l+flag&&s[l+flag]==s[r-flag]){
			flag++;
		}
		if(s[l+flag]<s[r-flag]){
			cout<<s[l];
			l++;
		}else{
			cout<<s[r];
			r--;
		}
		m++;
		if(m%80==0)cout<<endl;
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值