L - Fishing Master (贪心)

7 篇文章 0 订阅

Heard that eom is a fishing MASTER, you want to acknowledge him as your mentor. As everybody knows, if you want to be a MASTER’s apprentice, you should pass the trial. So when you find fishing MASTER eom, the trial is as follow:

There are n fish in the pool. For the i - th fish, it takes at least ti minutes to stew(overcook is acceptable). To simplify this problem, the time spent catching a fish is k minutes. You can catch fish one at a time and because there is only one pot, only one fish can be stewed in the pot at a time. While you are catching a fish, you can not put a raw fish you have caught into the pot, that means if you begin to catch a fish, you can’t stop until after k minutes; when you are not catching fish, you can take a cooked fish (stewed for no less than ti) out of the pot or put a raw fish into the pot, these two operations take no time. Note that if the fish stewed in the pot is not stewed for enough time, you cannot take it out, but you can go to catch another fish or just wait for a while doing nothing until it is sufficiently stewed.

Now eom wants you to catch and stew all the fish as soon as possible (you definitely know that a fish can be eaten only after sufficiently stewed), so that he can have a satisfying meal. If you can complete that in the shortest possible time, eom will accept you as his apprentice and say “I am done! I am full!”. If you can’t, eom will not accept you and say “You are done! You are fool!”.

So what’s the shortest time to pass the trial if you arrange the time optimally?
Input
The first line of input consists of a single integer T(1≤T≤20), denoting the number of test cases.

For each test case, the first line contains two integers n(1≤n≤105),k(1≤k≤109), denoting the number of fish in the pool and the time needed to catch a fish.

the second line contains n integers, t1,t2,…,tn(1≤ti≤109) ,denoting the least time needed to cook the i - th fish.
Output
For each test case, print a single integer in one line, denoting the shortest time to pass the trial.

Sample Input
2
3 5
5 5 8
2 4
3 3

Sample Output
23
11

Hint
Case 1: Catch the 3rd fish (5 mins), put the 3rd fish in, catch the 1st fish (5 mins), wait (3 mins),

take the 3rd fish out, put the 1st fish in, catch the 2nd fish(5 mins),

take the 1st fish out, put the 2nd fish in, wait (5 mins), take the 2nd fish out.

Case 2: Catch the 1st fish (4 mins), put the 1st fish in, catch the 2nd fish (4 mins),

take the 1st fish out, put the 2nd fish in, wait (3 mins), take the 2nd fish out.

题目大意:
第一行给出鱼的数量钓鱼时间n、k,第二行给出煮鱼的时间t1、t2、…、tn

  • 鱼要钓上来才可以煮
  • 可以边煮鱼边钓鱼,但在钓鱼的时候不能开始煮鱼
  • 问至少要多少时间才能把全部鱼煮熟

解题思路:
*把煮鱼时间以钓鱼时间k为单位时间划分,优先在钓鱼的时候把最大的煮鱼时间消耗掉

完整代码:

#include<iostream>
#include<algorithm>
using namespace std;
int t, m, n;
bool cmp(int a,int b){
	return a>b;
}
int main()
{
	long long a[100010];
	cin>>t;
	while(t--){
		scanf("%d%d",&n,&m);
		long long sum=(long long)m*n,d=1;	//至少的钓鱼时间和钓鱼次数 
		for(int i=0;i<n;i++){
			scanf("%lld",&a[i]);
			d+=a[i]/m;	//不浪费时间钓鱼的次数 
			a[i]%=m; 
			sum+=a[i];	//剩下的时间 
		}
		sort(a,a+n,cmp);
		for(int i=1;i<n;i++){
			a[i]+=a[i-1]; 
		}
		if(d>=n){		//可完整钓鱼次数多了仅用n次 
			sum+=(d-n)*m;
		}else{
			sum-=a[n-d-1];	//不够就补上 
		}
		cout<<sum<<endl;
	}
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值