M - Buy Sticks (贪心)

7 篇文章 0 订阅

Imyourgod need 3 kinds of sticks which have different sizes: 20cm, 28cm and 32cm. However the shop only sell 75-centimeter-long sticks. So he have to cut off the long stick. How many sticks he must buy at least.
Input
The first line of input contains a number t, which means there are t cases of the test data.
There will be several test cases in the problem, each in one line. Each test cases are described by 3 non-negtive-integers separated by one space representing the number of sticks of 20cm, 28cm and 32cm. All numbers are less than 10^6.
Output
The output contains one line for each line in the input case. This line contains the minimal number of 75-centimeter-long sticks he must buy. Format are shown as Sample Output.

Sample Input
2
3 1 1
4 2 2

Sample Output
Case 1: 2
Case 2: 3

题目大意:
要把长度为75的木棒切成特定数量规格为20、28或32的木棒,问至少需要多少条长度为75的木棍

解题思路:
一根75的木棍可以按以下切分

202832
300
210
201
011
002
020

可以看出28和32的作用是一样的,完全可以把32的当做28的来看,然后再看下表思路就清晰多了

2028
21
30
02

分析一下,当20和28的棍子都需要时,取2,1组合是最优的,直到一方被满足

完整代码:

#include<iostream>
using namespace std;
int main()
{
	int t;
	cin>>t;
	for(int i=0;i<t;i++){
		int a,b,c,sum=0;
		cin>>a>>b>>c;
		b+=c;		//将32的当28的对待 
		int d=(a+1)/2;		//求出2,1组合数 
		if(d>b){ 			//组合过多就回溯 
			a-=b*2;
			sum+=b+(a/3)+(a%3!=0);
		}else{			//正常组合数 
			b-=d;
			sum+=d+b/2+b%2;
		}
		cout<<"Case "<<i+1<<": "<<sum<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值