一、枚举法(例题4)熄灯问题(POJ 1222)

1222:EXTENDED LIGHTS OUT

总时间限制: 

1000ms

 内存限制: 

65536kB

描述

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:

1. It does not matter what order the buttons are pressed.

2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.

3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first

four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.

Write a program to solve the puzzle.

输入

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0抯 or 1抯 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

输出

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0抯 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

样例输入

2

0 1 1 0 1 0

1 0 0 1 1 1

0 0 1 0 0 1

1 0 0 1 0 1

0 1 1 1 0 0

0 0 1 0 1 0

1 0 1 0 1 1

0 0 1 0 1 1

1 0 1 1 0 0

0 1 0 1 0 0

样例输出

PUZZLE #1

1 0 1 0 0 1

1 1 0 1 0 1

0 0 1 0 1 1

1 0 0 1 0 0

0 1 0 0 0 0

PUZZLE #2

1 0 0 1 1 1

1 1 0 0 0 0

0 0 0 1 0 0

1 1 0 1 0 1

1 0 1 1 0 1

 

解题分析:

1、开关按几次有意义? (每个开关最多只需按下一次)
2、开关按下的顺序有关系吗?(没有关系)
3、枚举法(第一行开关就是”局部“)

从0 ~ 2^k-1,共2^k个数,表示2^k种状态

#include<iostream>
#include<cstring>
using namespace std;

char oriLights[5];   //初始灯状态矩阵,每个char元素表示一行灯的状态(用到了6位bit)
char lights[5];      //变化中灯状态矩阵
char result[5];      //开关的方案,用于输出

//获取某行某盏灯的状态
int GetBit(char c, int i)
{
	return (c >> i) & 1;
}

//将字符c的第i位的状态设置成v
void SetBit(char & c, int i, int v)
{
	if (v) {
		c |= (1 << i);
	}
	else
		c &= ~(1 << i);
}

//翻转第i位灯的状态
void FlipBit(char & c, int i)
{
	c ^= (1 << i);
}

//输出结果
void OutputResult(int t, char result[])
{
	cout << "PUZZLE #" << t << endl;
	for (int i = 0; i < 5; ++i) {
		for (int j = 0; j < 6; ++j) {
			cout << GetBit(result[i], j);
			if (j < 5)
				cout << " ";
		}
		cout << endl;
	}				
}

int main()
{
	int T;
	cin >> T;
	for (int t = 1; t <= T; ++t) {
		for (int i = 0; i < 5; ++i) {
			for (int j = 0; j < 6; ++j) {
				int tmp;
				cin >> tmp;
				SetBit(oriLights[i], j, tmp);
			}
		}
		//枚举第一行所有开关状态
		for (int n = 0; n < 64; ++n) {
			int switchs = n;
			memcpy(lights, oriLights, sizeof(oriLights));
			for (int i = 0; i < 5; ++i) {      //依次处理每一行
				//i行开关状态
				result[i] = switchs;
				//处理i行中各盏状态
				for (int j = 0; j < 6; ++j) {    
					if (GetBit(switchs, j)) {    //1表示按了
						if (j >= 1)
							FlipBit(lights[i], j-1);  
						FlipBit(lights[i], j);           
						if (j <= 4)
							FlipBit(lights[i], j + 1);  
					}
				}
				//处理i+1行状态
				if (i < 5) {
					lights[i + 1] ^= switchs;    //swiths的j位1(按下),则i+1行的j灯翻转(亮+1为0;暗+1为1)
				}
				//确当i+1行应有的开关状态,即为i行灯的状态(i行哪里亮,i+1就按对应位置开关)
				switchs = lights[i];
			}
			//最后一行都灭了
			if (lights[4] == 0) {
				OutputResult(t, result);
				break;
			}
		}
	}
	return 0;
}

 

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值