POJ - 1014 Dividing

Dividing

POJ - 1014

AYIT-2021 609暑假集训第一周下 记忆化搜索和背包

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.
The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output

For each collection, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

题意:一堆弹珠,每颗的价值不等,平均分成总价值相等两堆,看最后能不能平均分
题型:01背包
思路:首先排除总价值为奇数的情况,若是偶数则用背包

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int v[100010],n[7],dp[100010];
int main()
{
	int i,j,k,m,sum,t=0;
	while(~scanf("%d%d%d%d%d%d",&n[0],&n[1],&n[2],&n[3],&n[4],&n[5])&&(n[0]+n[1]+n[2]+n[3]+n[4]+n[5])
	{
		for(sum=i=0;i<6;i++)
			sum+=(i+1)*n[i];
		if((sum&1)||!sum)
		{
			printf("Collection #%d:\nCan't be divided.\n\n",++t);
			continue;
		}
		sum/=2;
		for(m=i=0;i<6;i++)
		{
			for(k=1;k<=n[i];k=k*2)
			{
				v[m++]=k*(i+1);
				n[i]-=k;
			}
			if(n[i]>0)
				v[m++]=n[i]*(i+1);
		}
		memset(dp,0,sizeof(dp));
		for(i=0;i<m;i++)
			for(j=sum;j>=v[i];j--)
				dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
		if(dp[sum]==sum)
			printf("Collection #%d:\nCan be divided.\n",++t);	
		else
			printf("Collection #%d:\nCan't be divided.\n",++t);	
		puts("");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值