Problem A: 自定义字符串的下标运算

Description

定义类MyString,由长度不超过100的字符串组成。重载其下标运算符:

int operator[](char ch)

用于重复求指定字符ch在串中的下标。

重载其输入运算符,用于输入字符串。

Input

输入一个不含空白符的字符串(长度不超过100个)和一个字符。

Output

指定字符在字符串中的所有位置。

Sample Input

babababaab a

Sample Output

1

3

5

7

8

-1

HINT

下标运算符中需要用到静态变量。

禁止使用STL,包括list、vector和string等。

Append Code

int main()
{
    MyString mystr;
    char c;
    int pos;
    cin>>mystr>>c;
    do{
        pos = mystr[c];
        cout<<pos<<endl;
    }while(pos != -1);
    return 0;
}

Accepted Code

#include<iostream>
using namespace std;

class MyString
{
private:
    char mystr[101];
public:
    static int t;
    friend istream& operator >>(istream&,MyString&);
    int operator[](char ch)
    {
        while(mystr[t]!='\0')
        {
            if(mystr[t]==ch)
            {
                t++;
                return t-1;
            }
            else
            {
                t++;
            }
        }
        return -1;
    }
};
int MyString::t=0;
istream &operator>>(istream &is,MyString &c)
{
    char mystr[101];
    is>>c.mystr;
    return is;
}
int main()
{
    MyString mystr;
    char c;
    int pos;
    cin>>mystr>>c;
    do
    {
        pos = mystr[c];
        cout<<pos<<endl;
    }
    while(pos != -1);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 定义一个Point类,表示平面上的点,具有x和y两个坐标成员变量,以及设置和获取坐标的方法。还要实现计算两点之间距离的方法。 输入描述 无输入。 输出描述 无输出。 样例 无样例。 提示 要求定义Point类,具有如下成员: 成员变量: double x:表示点的横坐标。 double y:表示点的纵坐标。 成员函数: Point():构造函数,将x和y初始值为0.0。 Point(double x, double y):构造函数,将x和y初始值为参数值。 void setX(double x):设置点的横坐标。 double getX():获取点的横坐标。 void setY(double y):设置点的纵坐标。 double getY():获取点的纵坐标。 double distance(Point another):计算当前点与另外一个点之间的距离,返回距离值。 注意:在类的实现中,要包含头文件cmath,使用其中的sqrt函数求平方根。 C++ 代码 ```cpp #include <iostream> #include <cmath> using namespace std; class Point { private: double x, y; public: Point() : x(0.0), y(0.0) {} Point(double x, double y) : x(x), y(y) {} void setX(double x) { this->x = x; } double getX() { return x; } void setY(double y) { this->y = y; } double getY() { return y; } double distance(Point another) { double dx = x - another.x; double dy = y - another.y; return sqrt(dx * dx + dy * dy); } }; int main() { Point p1, p2(3.0, 4.0); p1.setX(1.0); p1.setY(2.0); cout << "p1: (" << p1.getX() << ", " << p1.getY() << ")" << endl; cout << "p2: (" << p2.getX() << ", " << p2.getY() << ")" << endl; cout << "distance between p1 and p2: " << p1.distance(p2) << endl; return 0; } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值