拓扑排序 2-权值排序

 

 


 

1.引入库

代码如下(示例):

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?



Input
The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.



Output
For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

2.读入数据

代码如下(示例):

Sample Input
5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2
Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

注意本题是按照权值排序:
即:4 1
       3 2
    1 3 2 4  对应 1 2 3 4
故  a[1]=1,a[3]=2,a[2]=3,a[4]=4;
则:a[1]=1,a[2]=3,a[3]=2,a[4]=4,故结果为  1,3,2,4 

!!!且本题只能才用反拓扑排序即反向排序 如:4 1    选1入度为0 ,4入度为1 

三.代码如下:

#include<stdio.h>
#include<string.h>
using namespace std;
int vis[410],in[410],map[410][410],pa[410],n,m;
void toposort()
{
    int i,j;
    memset(vis,0,sizeof(vis));
    for(i = n ; i >= 1 ; i--) 
	{
        int l = 0;
        for(j = n ; j >= 1 ; j--)
		{
            if(!vis[j] && in[j] == 0)  //如果该点没有被记录过且入度为零 
			{
                l = j;  //记录它的权值 
                break;   
            }
        }
        if(!l)	//如果l依然等于零 
		{
            printf("-1\n");
            return ;
        }
        pa[l] = i;  //记录此时的位置 
        vis[l] = 1;  //标记 
        for(j = 1 ; j <= n ; j++)  //以l为起始边 与该边相连的顶点 入度减一 
            if(map[l][j])
                in[j]--;
    }
		for(int j=1;j<=n;j++)
		printf("%d%c",pa[j],j==n?'\n':' ');
}
int main()
{
    int T,a,b;
    scanf("%d",&T);
    while(T--)
    {
        memset(map,0,sizeof(map));
        memset(in,0,sizeof(in));
        scanf("%d %d",&n,&m);
        while(m--)
		{
            scanf("%d %d",&a,&b);
            if(!map[b][a])
                in[a]++;    //记录各个顶点的入度 
            map[b][a] = 1;  //记录各个边 
        }
        toposort();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

风遥~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值