HDU - 1003

子序列的最大和

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

题意:
计算子序列 (该子序列是连续的) 最大和
输出:该子序列的最大和 ,,该子序列起始位置 ,,该子序列结束位置
注意:起始点的位置并不是一成不变的

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

AC代码

#include<stdio.h>
#include<string.h>
int a[100100];
int main()
{
	int m,i,t,z=0;
	int max,x,y,j,sum;
	scanf("%d",&t);
	while(t--)
	{
		z++;
		 max=0,x=1,y=1;
		 sum=-1001,j=1;
		/
		scanf("%d",&m);
		for(i=1;i<=m;i++)
			scanf("%d",&a[i]);
		for(i=1;i<=m;i++)
		{
			max+=a[i];
			if(max>sum)
			{
				sum=max;
				x=j;
				y=i;	
			}
			if(max<0)
			{
				max=0;
				j=i+1;
			}
		}
		printf("Case %d:\n",z);
		printf("%d %d %d\n",sum,x,y);
		if(t!=0)
		printf("\n");
	}
	return 0;
}
/*
input
2
7 0 6 -1 1 -6 7 -5
out put 
Case 1:
7 1 6

// 0 也算在初始位中 
9 1 3 5 -5 4 2 1 -17 19	//这个样例可以试一下
out put
Case 2:
19 9 9
//	需要注意的地方
//只要(max 小于 0 且在之后有 max > sum ),起始点位置就发生变化 
// 当 max 小于 0 时, 有可能前面的数之和不是最大的 
//再从max < 0处 ,令max = 0(当做从起始点开始,或是以此为起始点),重新往后搜 找最大的和
*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值