mpls实验

题目要求如下:
1.R1与R5建立mpls
2.R6与R7建立mpls
3.R7可以访问R2,R3,R4的环回
在这里插入图片描述配置如下:

R1
sysname R1
 #                                       
interface GigabitEthernet0/0/0            
 ip address 192.168.2.1 255.255.255.0     
#                                       
interface LoopBack0                       
 ip address 192.168.1.1 255.255.255.0     
#                                         
ip route-static 192.168.3.0 255.255.255.0 192.168.2.2
ip route-static 192.168.4.0 255.255.255.0 192.168.2.2

R2
sysname R2
#
ip vpn-instance a1                      //创建空间
 ipv4-family                           //DR值
  route-distinguisher 2:2 
  vpn-target 2:2 export-extcommunity    //TR值
  vpn-target 2:2 import-extcommunity
#
ip vpn-instance b1
 ipv4-family
  route-distinguisher 1:1
  vpn-target 1:1 export-extcommunity      
  vpn-target 1:1 import-extcommunity      
#                                         
mpls lsr-id 2.2.2.2                               //指定mplsid1号
mpls                                          //开启mpls
#                                         
mpls ldp                                  
#                                                                                 
interface GigabitEthernet0/0/0            
 ip address 23.1.1.1 255.255.255.0        
 mpls                                     //在接口上开启mpls
 mpls ldp                                  
#                                         
interface GigabitEthernet0/0/1            
 ip binding vpn-instance b1               //要先绑定端口再配地址,不然IP地址会出现在共有路由表中
 ip address 192.168.2.2 255.255.255.0     
#                                         
interface GigabitEthernet0/0/2            
 ip binding vpn-instance a1               
 ip address 192.168.2.2 255.255.255.0     
#                                                                                
interface LoopBack0                       
 ip address 2.2.2.2 255.255.255.255       
#                                         
bgp 1                                     
 router-id 2.2.2.2                        
 peer 4.4.4.4 as-number 1                 
 peer 4.4.4.4 connect-interface LoopBack0 
 #                                        
 ipv4-family unicast                      
  undo synchronization                    
  peer 4.4.4.4 enable                     
 #                                        
 ipv4-family vpnv4                        
  policy vpn-target                       
  peer 4.4.4.4 enable                     
 #                                        
 ipv4-family vpn-instance a1                   //在bgp中 a1的路由
  import-route rip 1                      
 #                                        
 ipv4-family vpn-instance b1              
  import-route direct                         //在bgp向 b1导入静态和直连路由,不能书写,因为手写bgp不会打第二层标签
  import-route static                     
#                                         
ospf 1 router-id 2.2.2.2                  
 area 0.0.0.0                             
  network 2.2.2.2 0.0.0.0                 
  network 23.1.1.1 0.0.0.0                
#                                         
rip 1 vpn-instance a1                     //为空间起动态路由协议
 undo summary                             
 version 2                                
 network 192.168.2.0                      
 import-route bgp                         
#                                         
ip route-static vpn-instance b1 192.168.1.0 255.255.255.0 192.168.2.1

R3
sysname R3
#
mpls lsr-id 3.3.3.3
mpls
#
mpls ldp
#                                                                                
interface GigabitEthernet0/0/0            
 ip address 34.1.1.1 255.255.255.0        
 mpls                                     
 mpls ldp                                 
#                                         
interface GigabitEthernet0/0/1            
 ip address 23.1.1.2 255.255.255.0        
 mpls                                     
 mpls ldp                                 
#                                         
interface GigabitEthernet0/0/2            
#                                                                                  
interface LoopBack0                       
 ip address 3.3.3.3 255.255.255.255       
#                                         
ospf 1 router-id 3.3.3.3                  
 area 0.0.0.0                             
  network 3.3.3.3 0.0.0.0                 
  network 23.1.1.2 0.0.0.0                
  network 34.1.1.1 0.0.0.0

R4
sysname R4
#
ip vpn-instance a1
 ipv4-family
  route-distinguisher 2:2
  vpn-target 2:2 export-extcommunity
  vpn-target 2:2 import-extcommunity
#
ip vpn-instance b1
 ipv4-family                              
  route-distinguisher 1:1                 
  vpn-target 1:1 export-extcommunity      
  vpn-target 1:1 import-extcommunity      
#                                         
mpls lsr-id 4.4.4.4                       
mpls                                      
#                                         
mpls ldp                                  
#                                                                                                                                                                
interface GigabitEthernet0/0/0            
 ip binding vpn-instance b1               
 ip address 192.168.3.2 255.255.255.0     
#                                         
interface GigabitEthernet0/0/1            
 ip address 34.1.1.2 255.255.255.0        
 mpls                                     
 mpls ldp                                 
#                                         
interface GigabitEthernet0/0/2            
 ip binding vpn-instance a1               
 ip address 192.168.3.2 255.255.255.0     
#                                         
interface GigabitEthernet4/0/0            
 ip address 47.1.1.1 255.255.255.0        
#                                         
interface NULL0                           
#                                         
interface LoopBack0                       
 ip address 4.4.4.4 255.255.255.255       
#                                         
bgp 1                                     
 router-id 4.4.4.4                        
 peer 2.2.2.2 as-number 1                 
 peer 2.2.2.2 connect-interface LoopBack0 
 #                                        
 ipv4-family unicast                      
  undo synchronization                    
  peer 2.2.2.2 enable                     
 #                                        
 ipv4-family vpnv4                        
  policy vpn-target                       
  peer 2.2.2.2 enable                     
 #                                        
 ipv4-family vpn-instance a1              
  import-route ospf 2                     
 #                                        
 ipv4-family vpn-instance b1              
  import-route direct                     
  import-route static                     
#                                         
ospf 1 router-id 4.4.4.4                  
 area 0.0.0.0                             
  network 4.4.4.4 0.0.0.0                 
  network 34.1.1.2 0.0.0.0                
#                                         
ospf 2 router-id 4.4.4.4 vpn-instance a1  
 import-route bgp                         
 area 0.0.0.0                             
  network 192.168.3.2 0.0.0.0             
#                                         
ip route-static vpn-instance a1 192.168.4.0 255.255.255.0 192.168.3.1
ip route-static vpn-instance b1 192.168.4.0 255.255.255.0 192.168.3.1

sysname R5
#                                         
interface GigabitEthernet0/0/1            
 ip address 192.168.3.1 255.255.255.0                              
#                                         
interface LoopBack0                       
 ip address 192.168.4.1 255.255.255.0     
#                                         
ip route-static 192.168.1.0 255.255.255.0 192.168.3.2
ip route-static 192.168.2.0 255.255.255.0 192.168.3.2

R6
sysname R6
#                                       
interface GigabitEthernet0/0/0            
 ip address 192.168.2.1 255.255.255.0     
#                                                                                 
interface LoopBack0                       
 ip address 192.168.1.1 255.255.255.0     
#                                         
rip 1                                     
 undo summary                             
 version 2                                
 network 192.168.1.0                      
 network 192.168.2.0   

sysname R7
#                                        
interface GigabitEthernet0/0/0            
 ip address 192.168.3.1 255.255.255.0     
#                                         
interface GigabitEthernet0/0/1            
 ip address 47.1.1.2 255.255.255.0        
#                                         
interface GigabitEthernet0/0/2            
#                                                                                 
interface LoopBack0                       
 ip address 192.168.4.2 255.255.255.0     
#                                         
ospf 1 router-id 7.7.7.7                  
 area 0.0.0.0                             
  network 192.168.3.1 0.0.0.0             
  network 192.168.4.2 0.0.0.0 
# 
ip route-static 0.0.0.0 0.0.0.0 192.168.3.2
  • 6
    点赞
  • 26
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小时候不乖的

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值