网络类型实验

在这里插入图片描述
R5 为ISP,只能进行IP地址配置;其所在接口配置为公有IP地址
R1和R5之间使用PPP的PAP认证,R5为主认证方
R2和R5之间使用PPP的CHAP认证,R5为主认证方
R3 和 R5 之间使用HDLC封装
R1\2\3构建一个MGRE环境,R1为中心站点
R1和R4间为点到点GRE

r1配置:

[r1-GigabitEthernet0/0/0]ip ad	
[r1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[r1]dhcp enable 
[r1]ip pool 1
[r1-ip-pool-1]network 192.168.1.0 mask 24
[r1-ip-pool-1]gateway-list 192.16.1.1
[r1-ip-pool-1]gateway-list 192.168.1.1
[r1-ip-pool-1]dns-list 114.114.114.114 8.8.8.8
[r1]int g0/0/0
[r1-GigabitEthernet0/0/0]dhcp select global 

r2配置:

[r2]int g0/0/0
[r2-GigabitEthernet0/0/0]ip address 192.168.2.1 24
[r2]dhcp enable 
[r2]ip pool 2
[r2-ip-pool-2]network 192.168.2.0 mask 24
[r2-ip-pool-2]gateway-list 192.168.2.1
[r2-ip-pool-2]dns-list 114.114.114.114 8.8.8.8
[r2-ip-pool-2]int g0/0/0
[r2-GigabitEthernet0/0/0]dhcp select global 

r3配置:

[r3]int g0/0/0
[r3-GigabitEthernet0/0/0]ip address 192.168.3.1 24
[r3]dhcp enable 
[r3]ip pool 3
[r3-ip-pool-3]network 192.168.3.0 mask 24
[r3-ip-pool-3]gateway-list 192.168.3.1
[r3-ip-pool-3]dns-list 114.114.114.114 8.8.8.8
[r3-ip-pool-3]int g0/0/0
[r3-GigabitEthernet0/0/0]dhcp select global 

r4配置:

[r4]int g0/0/0
[r4-GigabitEthernet0/0/0]ip address 192.168.4.1 24
[r4]dhcp enable 
[r4]ip pool 4                                     
[r4-ip-pool-4]network 192.168.4.0 mask 24
[r4-ip-pool-4]gateway-list 192.168.4.1
[r4-ip-pool-4]dns-list 114.114.114.114 8.8.8.8
[r4-ip-pool-4]int g0/0/0
[r4-GigabitEthernet0/0/0]dhcp select global 

pc端以获取地址
在这里插入图片描述
r1:
[r1]int s4/0/0
[r1-Serial4/0/0]ip add 15.1.1.1 24

r2:
[r2]int s4/0/0
[r2-Serial4/0/0]ip add 25.1.1.1 24

r3:
[r3]int s4/0/0
[r3-Serial4/0/0]ip add 35.1.1.1 24

r4:
[r4]int s4/0/0
[r4-Serial4/0/0]ip add 45.1.1.1 24

isp:

[isp]int s3/0/0
[isp-Serial3/0/0]ip add 15.1.1.2 24

[isp-Serial3/0/0]int s3/0/1
[isp-Serial3/0/1]ip add 25.1.1.2 24

[isp-Serial3/0/1]int s4/0/1
[isp-Serial4/0/1]ip add 35.1.1.2 24

[isp-Serial4/0/1]int s4/0/0
[isp-Serial4/0/0]ip add 45.1.1.2 24

检测:
在这里插入图片描述
主认证方:

[isp]aaa
[isp-aaa]local-user huawei password cipher abc123
[isp-aaa]local-user huawei service-type ppp
[isp-aaa]int s3/0/0
[isp-Serial3/0/0]link-protocol ppp
[isp-Serial3/0/0]ppp authentication-mode pap

[r1]int s4/0/0
[r1-Serial4/0/0]link-protocol ppp
[r1-Serial4/0/0]ppp pap local-user huawei password cipher abc123
[isp]aaa
[isp-aaa]local-user huawei password cipher abc123
[isp-aaa]local-user huawei service-type ppp
[isp-aaa]int s3/0/1
[isp-Serial3/0/1]link-protocol ppp
[isp-Serial3/0/1]ppp authentication-mode pap

[r2]int s4/0/0
[r2-Serial4/0/0]link-protocol ppp
[r2-Serial4/0/0]ppp pap local-user huawei password cipher abc123

HDLC

[r3]int s4/0/0
[r3-Serial4/0/0]link-protocol hdlc

[isp]int s4/0/1
[isp-Serial4/0/1]link-protocol hdlc

MGRE
r1:

[r1]int Tunnel 0/0/0
[r1-Tunnel0/0/0]ip address 10.1.1.1 24
[r1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r1-Tunnel0/0/0]source 15.1.1.1
[r1-Tunnel0/0/0]nhrp entry multicast dynamic  
[r1-Tunnel0/0/0]nhrp network-id 100
[r1]rip 1 
[r1-rip-1]version 2
[r1-rip-1]undo summary 
[r1-rip-1]network 192.168.1.0
[r1-rip-1]network 10.0.0.0
[r1-rip-1]network 20.0.0.0

r2:

[r2]int Tunnel 0/0/0
[r2-Tunnel0/0/0]ip ad 10.1.1.2 24
[r2-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r2-Tunnel0/0/0]source Serial 4/0/1
[r2-Tunnel0/0/0]nhrp network-id 100
[r2-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register  
[r2]rip 1
[r2-rip-1]version 2
[r2-rip-1]undo summary 
[r2-rip-1]network 192.168.2.0
[r2-rip-1]network 10.0.0.0

r3:

[r3]int Tunnel 0/0/0
[r3-Tunnel0/0/0]ip address  10.1.1.3 24
[r3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r3-Tunnel0/0/0]source Serial 3/0/0
[r3-Tunnel0/0/0]nhrp network-id 100
[r3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register 
[r3]rip 1
[r3-rip-1]version 2
[r3-rip-1]undo summary 
[r3-rip-1]network 192.168.3.0
[r3-rip-1]network 10.0.0.0

GRE

[r1]int t 0/0/1
[r1-Tunnel0/0/1]ip address 14.1.1.1 24
[r1-Tunnel0/0/1]tunnel-protocol gr
[r1-Tunnel0/0/1]source 15.1.1.1
[r1-Tunnel0/0/1]destination 45.1.1.1
[r1]ip route-static 192.168.4.0 24 Tunnel 0/0/1

[r4]interface Tunnel 0/0/1
[r4-Tunnel0/0/1]ip address 14.1.1.2 24
[r4-Tunnel0/0/1]tunnel-protocol gr
[r4-Tunnel0/0/1]source 45.1.1.1
[r4-Tunnel0/0/1]destination 15.1.1.1
[r4]ip route-static 192.168.1.0 24 Tunnel 0/0/1
[r4]rip 1
[r4-rip-1]undo summary
[r4-rip-1]version 2
[r4-rip-1]network 192.168.4.0
[r4-rip-1]network 20.0.0.0
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值