1146 Topological Order

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
6
5 2 3 6 4 1
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

0 4 5
#include <iostream>
#include <vector>
using namespace std;
int n, m, k, u, v, cnt;
int ind[1010], t[1010], a[1010], ans[1010];
vector<int>g[1010];

int main() {
	cin >> n >> m;
	for (int i = 0; i < m; i++) {
		cin >> u >> v;
		ind[v]++;
		g[u].push_back(v);
	}
	cin >> k;
	int cnt = 0;
	for (int c = 0; c < k; c++) {
		bool flag = 0;
		for (int i = 1; i <= n; i++) {
			t[i] = ind[i];
		}
		for (int i = 0; i < n; i++) {
			cin >> a[i];
			if (flag) {
				continue;
			}
			if (t[a[i]] != 0) {
				flag = 1;
			} else {
				for (int j = 0; j < g[a[i]].size(); j++) {
					t[g[a[i]][j]]--;
				}
			}
		}
		if (flag) {
			ans[cnt++] = c;
		}
	}
	for (int i = 0; i < cnt; i++) {
		cout << ans[i];
		if (i != cnt - 1) {
			cout << ' ';
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值