(有逐步注解)1003. Emergency (25)-PAT甲级真题(Dijkstra算法)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 题目大意:作为一个城市紧急援救队的指挥者,你得到了一个国家的特殊地图。已知地图上每个城市的援救队数量,以及两座城市之间每条道路的长度。当某个城市需要紧急帮助,你需要带领你的队伍以最快的速度赶到事发现场,与此同时,召集尽可能多的在路上的救援队。


//伪代码:

从当前点出发

{
       if( 发现能到达v,而且距离比其他路更短){

                更新最短路径;
    }
       else( 发现能到达v,但距离与其他路相等)
                路径数量+1;
}

 

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
int n, m, c1, c2;	//城市数量n,道路数量m, c1当前所在城市编号,c2救援城市编号 
int e[510][510], weight[510], dis[510], num[510], w[510];
//dis[i]从出发点到i结点最短路径的路径长度 
//num[i]从出发点到i结点最短路径条数,w[i]出发点到i点救援队数目之和 
bool visit[510];
const int inf = 99999999;
int main() {
    scanf("%d%d%d%d", &n, &m, &c1, &c2);//城市数量n,道路数量m, c1当前所在城市编号,c2救援城市编号 
    for(int i = 0; i < n; i++)
    scanf("%d", &weight[i]);//weight[i] 第i个城市救援队数量	 
    fill(e[0], e[0] + 510 * 510, inf);//fill(开始位置,个数,替换的数) inf=9999999,e[a][b]储存a-b间道路距离 
    fill(dis, dis + 510, inf);//同上,填充dis数组
    int a, b, c;
    for(int i = 0; i < m; i++) {
        scanf("%d%d%d", &a, &b, &c);//a,b城市之间道路长度为c 
        e[a][b] = e[b][a] = c;//e[a][b]储存a-b间道路距离 
    }   
    w[c1] = weight[c1];//在出发点时,当前救援队总数量w[c1]为出发点救援队数量weight[c1]  
    num[c1] = 1;//num[i]从出发点到i结点最短路径条数
    dis[c1] = 0;//dis[i]从出发点到i结点最短路径的路径长度     
    for(int i = 0; i < n; i++) {//i控制次数,n个城市,一共n次 	
        int u = -1, minn = inf;       
        for(int j = 0; j < n; j++) {//城市数量         
            if(visit[j] == false && dis[j] < minn) {//如果结点未访问,且最短路径小于最小值 
                u = j;//u =当前最短路径终点u 
                minn = dis[j];//minn 存最短路径长度 
            }            
        }       
        if(u == -1) break;//u=-1代表全部都访问过了 ,就退出了 
        visit[u] = true;//开始访问		 
        for(int v = 0; v < n; v++) {//城市数量遍历         	
            if(visit[v] == false && e[u][v] != inf) {//如果点v还没被访问&&当前点到点v有路,则进入 
            	//两种情况		
				//第一种,发现这是捷径: 
                if(dis[u] + e[u][v] < dis[v]) {//当前点u的最短路径长度+点u到点v的路径长度 < 当前能到点v的最短路径长度                   
					dis[v] = dis[u] + e[u][v];//更新到达点v的最短路径长度 
                    num[v] = num[u];//到达点v的路径条数=到达点u的路径条数 
                    w[v] = w[u] + weight[v];//从出发点到v救援队数目之和=w的救援队之和+v这一点的救援队数量                   
                //第二种,发现长度与另一条最短路相等 
                } else if(dis[u] + e[u][v] == dis[v]) {//当前点u的最短路径长度+点u到点v的路径长度 = 当前能到点v的最短路径长度 
                    num[v] = num[v] + num[u];//能到达点v的条数=原来到达v的条数+能到达u的条数 
                    if(w[u] + weight[v] > w[v])//if(u点的总救援队+v点的救援队>v点总救援队> 
                        w[v] = w[u] + weight[v];//更新v点总救援队数量 
                }
            }
            
        }        
    }    
    printf("%d %d", num[c2], w[c2]);//输出目标城市的路径条数,最多救援数量 
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值