As Easy As A+B (HDU - 1040)(快速排序)

As Easy As A+B (HDU - 1040)(快速排序)

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9

1. 可以用系统自带的函数。 

2. 快速排序(利用双指针算法)

​
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
const int MAX = 1e3+5;

void swap(int &a, int &b){
    int temp = b;
    b = a;
    a = temp;
}

// i=l-1是因为循环一开始就i++会判断不到0的情况,j=r+1因为j=r也要判断不然无法判断j=r的情况
// 当i < j 时但是a[i] = a[j] = x时不会无限循环,因为无论怎样i和j都会变大
// 但是这种排序最慢可能是O(n2)的,当数组本身有序,就会每个都遍历
void quicksort(int a[], int l, int r)
{
    if(l >= r) return;
    int i = l - 1, j = r + 1, x = a[l + r >> 1];
    while(i < j)
    {        
		do i++; while(a[i] < x);
        do j--; while(a[j] > x);
        if(i < j) swap(a[i], a[j]);
    }
    quicksort(a, l, j);
	quicksort(a, j + 1, r);
}

int main(){
    int t;cin >> t;
	while (t--) {
		int a[MAX] = {0};
		int n; cin >> n;
		for (int i=0; i < n; i++) {
			cin >> a[i];
		}
		quicksort(a, 0, n - 1);
		cout << a[0];
		for(int i = 1; i < n; i++) {
			cout << " " << a[i];
		}
		cout << '\n';
	}

    return 0;
}

​

3.归并排序

​
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

#define ll long long
const int MAX = 1e5+5;
int a[MAX], tmp[MAX];

//该排序是将每个元素分为一个再按从小到大的顺序拼接起来
//也利用了双指针a[i]和a[j]对比谁小就复制到tmp上
//后面两个循环是因为到最后可能i还没到mid或j还没到r 还有数
//因为那些数已经有序可以直接复制到tmp上
//最后把tmp复制到啊a上
void quick_sort(int a[], int l, int r) {	
	if (l >= r) return;
	int mid = (l + r) / 2;
	quick_sort(a, l, mid);
	quick_sort(a, mid + 1, r);

	int i = l, j = mid + 1, k = 0; 
	while (i <= mid && j <= r) {
		if (a[i] <= a[j]) tmp[k++] = a[i++];
		else tmp[k++] = a[j++]; 
	}
	while (i <= mid) tmp[k++] = a[i++];
	while (j <= r) tmp[k++] = a[j++];
	for (int i = l , j = 0; j < k; j++) {
		a[i++] = tmp[j];
	}
}

int main(){
    int t;cin >> t;
	while (t--) {
		int a[MAX] = {0};
		int n; cin >> n;
		for (int i=0; i < n; i++) {
			cin >> a[i];
		}
		quick_sort(a, 0, n - 1);
		cout << a[0];
		for(int i = 1; i < n; i++) {
			cout << " " << a[i];
		}
		cout << '\n';
	}

    return 0;
}

​

总结:这题可以用多种方法做,更多的是学习其他方法的思路 。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值