Aggressive cows POJ - 2456(二分)

农夫约翰面临一个挑战,他需要在新建的畜棚中安排奶牛,以确保它们之间的最小距离最大化,以避免冲突。给定畜棚的位置和奶牛的数量,通过优化策略找到能让奶牛间距离最大的分配方案。程序输入包括畜棚数量和奶牛数量,以及每个畜棚的位置,输出是最大可能的最小距离。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
    Output

  • Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

翻译

农夫约翰建了一个新的长谷仓,有N个(2个)畜棚,畜棚沿直线位于x1,,XN(0 <=x<=1000000000)。
他有C(2<=C<=N)头奶牛,它们不喜欢这种畜棚布局,一旦放进畜棚,它们就会互相攻击。为了防止母牛相互伤害,FJ希望将母牛分配到畜棚,任意两个畜棚之间的最小距离尽可能大。最大最小距离是多少?
输入
*第1行:两个空格分隔的整数:N和C
*第2行。。N+ 1:行I+1为整数畜棚位置,
*第1行:一个整数:最大最小距离

暗示

输出详细信息:
FJ可以把他的3头牛放在位置1、4和8的档位上,因此最大最小距离为3。
输入数据量大,建议使用scanf。

代码

#include "stdio.h"
#include "algorithm"
using namespace std;
int a[100009];
int n,m;
int ppp(int mid)
{
	int s=0,i=0;
	for(int j=1;j<n;j++)
	{
		if(a[j]-a[i]>=mid) i=j;
		else s++;//第j个畜棚不用,故s++
	}
	if(s<=m) return 1;//s<m,mid取小了,s=m时判断m可以更大些吗
	return 0;
}
int main()
{
	scanf("%d %d",&n,&m);
	for(int i=0; i<n; i++)
		scanf("%d",&a[i]);	
	m=n-m;//有几个畜棚不用
	sort(a,a+n);
	int k=0,j=a[n-1]-a[0];
	while(k<=j)
	{
		int mid=(k+j)/2;
		if(ppp(mid))
			k=mid+1;
		else
			j=mid-1;
	}
	printf("%d\n",k-1);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值