Description
编写一个程序实现将字符串中的所有”you”替换成”we”
Input
输入包含多行数据
每行数据是一个字符串,长度不超过1000
数据以EOF结束
Output
对于输入的每一行,输出替换后的字符串
Sample Input
you are what you do
Sample Output
we are what we do
①利用string函数
#include<bits/stdc++.h>
using namespace std;
int main()
{
string str;
while(getline(cin,str))
{
int start=str.find("you");
while(start!=string::npos)//保证不是字符串尾
{
str.replace(start,3,"we");
start=str.find("you",start+2);
}
cout<<str<<endl;
}
return 0;
}
②不利用string函数
#include<bits/stdc++.h>
using namespace std;
int main()
{
int i=0,j;
char a[1001];
while(scanf("%s",a)!=EOF)
{
if(strcmp(a,"you")==0)
strcpy(a,"we");
cout<<a<<' ';
}
return 0;
}