链式表操作集

要求实现链式表的操作集。

函数接口定义:

Position Find(List L,ElementType X);
List Insert(List L,ElementType X, Position P);
List Delete(List L,Position P);

其中List结构定义如下:

typedef struct LNode *PtrToLNode;
struct LNode 
{
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;

各个操作函数定义为:
Position Find( List L, ElementType X ):返回线性表中首次出现X的位置。若找不到则返回ERROR;
List Insert( List L, ElementType X, Position P ):将X插入在位置P指向的结点之前,返回链表的表头。如果参数P指向非法位置,则打印“Wrong Position for Insertion”,返回ERROR;
List Delete( List L, Position P ):将位置P的元素删除并返回链表的表头。若参数P指向非法位置,则打印“Wrong Position for Deletion”并返回ERROR。

输入样例:

6
12 2 4 87 10 2
4
2 12 87 5

输出样例:

2 is found and deleted.
12 is found and deleted.
87 is found and deleted.
Finding Error: 5 is not in.
5 is inserted as the last element.
Wrong Position for Insertion
Wrong Position for Deletion
10 4 2 5 
#include<iostream>
#include<stdlib.h>
using namespace std;
#define ERROR NULL
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode 
{
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;
Position Find(List L,ElementType X)
{
	List q=L;
	if(!L)
	{
		return ERROR;
	}
	while(q)
	{
		if(q->Data==X)
		{
			return q;
		}
		q=q->Next;
	}
	return ERROR;
}
List Insert(List L,ElementType X,Position P)
{
	List q=L;
	if(L==P)
	{
		q=(List)malloc(sizeof(struct LNode));
		q->Data=X;
		q->Next=P;
		return q;
	}
	while(L&&L->Next!=P)
	{
		L=L->Next;
	}
	if(!L)
	{
		cout<<"Wrong Position for Insertion"<<endl;
		return ERROR;
	}
	L->Next=(List)malloc(sizeof(struct LNode));
	L->Next->Data=X;
	L->Next->Next=P;
	return q;
}
List Delete(List L,Position P)
{
	if(L==P)
	{
		List q=L;
		L=L->Next;
		free(q);
		return L;
	}
	List r=L;
	while(L&&L->Next!=P)
	{
		L=L->Next;
	}
	if(!L)
	{
		cout<<"Wrong Position for Deletion"<<endl;
		return ERROR;
	}
	L->Next=P->Next;
	free(P);
	return r;
}
int main()
{
    List L=NULL;
    ElementType X;
    Position P,tmp;
    int N;
    cin>>N;
    while(N--) 
	{
        cin>>X;
        L=Insert(L,X,L);
        if(L==ERROR)
		{
			cout<<"Wrong Answer"<<endl;
	    }
    }
    cin>>N;
    while(N--) 
	{
        cin>>X;
        P=Find(L,X);
        if(P==ERROR)
        {
        	cout<<"Finding Error: "<<X<<" is not in."<<endl;
		}
        else 
		{
            L=Delete(L,P);
            cout<<X<<" is found and deleted."<<endl;
            if(L==ERROR)
            {
            	cout<<"Wrong Answer or Empty List."<<endl;
			}
        }
    }
    L=Insert(L,X,NULL);
    if(L==ERROR)
	{
		cout<<"Wrong Answer"<<endl;
	} 
    else
    {
    	cout<<X<<" is inserted as the last element."<<endl;
	}
    P=(Position)malloc(sizeof(struct LNode));
    tmp=Insert(L,X,P);
    if(tmp!=ERROR)
	{
		cout<<"Wrong Answer"<<endl;
	} 
    tmp=Delete(L,P);
    if(tmp!=ERROR)
	{
		cout<<"Wrong Answer"<<endl;
	}
    for(P=L;P;P=P->Next) 
	{
		cout<<P->Data<<" ";
	}
    return 0;
}

在这里插入图片描述

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

FG.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值