带头结点的链式表操作集

要求实现带头结点的链式表操作集。

函数接口定义:

List MakeEmpty(); 
Position Find( List L, ElementType X );
bool Insert( List L, ElementType X, Position P );
bool Delete( List L, Position P );

其中List结构定义如下:

typedef struct LNode *PtrToLNode;
struct LNode {
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;

各个操作函数的定义为:
List MakeEmpty():创建并返回一个空的线性表;
Position Find( List L, ElementType X ):返回线性表中X的位置。若找不到则返回ERROR;
bool Insert( List L, ElementType X, Position P ):将X插入在位置P指向的结点之前,返回true。如果参数P指向非法位置,则打印“Wrong Position for Insertion”,返回false;
bool Delete( List L, Position P ):将位置P的元素删除并返回true。若参数P指向非法位置,则打印“Wrong Position for Deletion”并返回false。

输入样例:

6
12 2 4 87 10 2
4
2 12 87 5

输出样例:

2 is found and deleted.
12 is found and deleted.
87 is found and deleted.
Finding Error: 5 is not in.
5 is inserted as the last element.
Wrong Position for Insertion
Wrong Position for Deletion
10 4 2 5 
#include<iostream>
#include<stdlib.h>
using namespace std;
#define ERROR NULL
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode 
{
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode Position;
typedef PtrToLNode List;
List MakeEmpty()
{
	List L=(List)malloc(sizeof(struct LNode));
	L->Next=NULL;
	return L;
}
Position Find( List L, ElementType X )
{
	L=L->Next;
	while(L)
	{
		if(L->Data==X)
		{
			return L;
		}
		L=L->Next;
	}
	return ERROR;
}
bool Insert( List L, ElementType X, Position P )
{
	List q=(List)malloc(sizeof(List));
	q->Data=X;
	q->Next=NULL;
	List r=L;
	while(r)
	{
		if(r->Next==P)
		{
			q->Next=P;
			r->Next=q;
			return true;
		}
		r=r->Next;
	}
	cout<<"Wrong Position for Insertion"<<endl;
	return false;
}
bool Delete( List L, Position P )
{
	if(L==P)
	{
		L=L->Next;
		return true;
	}
	while(L)
	{
		if(L->Next==P)
		{
			L->Next=P->Next;
			return true;
		}
		L=L->Next;
	}
	cout<<"Wrong Position for Deletion"<<endl;
	return false;
}
int main()
{
    List L;
    ElementType X;
    Position P;
    int N;
    bool flag;
    L=MakeEmpty();
    cin>>N;
    while(N--) 
	{
        cin>>X;
        flag=Insert(L, X, L->Next);
        if(flag==false) 
		{
			cout<<"Wrong Answer"<<endl;
		}
    }
    cin>>N;
    while(N--) 
	{
        cin>>X;
        P=Find(L, X);
        if(P==ERROR)
        {
        	cout<<"Finding Error: "<<X<<" is not in."<<endl;
	    }
        else 
		{
            flag=Delete(L, P);
            cout<<X<<" is found and deleted."<<endl;
            if(flag==false)
            {
            	cout<<"Wrong Answer."<<endl;
			}
        }
    }
    flag=Insert(L, X, NULL);
    if(flag==false) 
	{
		cout<<"Wrong Answer"<<endl;
	}
    else
    {
    	cout<<X<<" is insered as the last element."<<endl;
	}
    P=(Position)malloc(sizeof(struct LNode));
    flag=Insert(L, X, P);
    if(flag==true) 
	{
		cout<<"Wrong Answer"<<endl;
	}
    flag=Delete(L, P);
    if(flag==true)
	{
		cout<<"Wrong Answer"<<endl;
	}
    for(P=L->Next;P;P=P->Next) 
	{
		cout<<P->Data<<" ";
	}
    return 0;
}

在这里插入图片描述

  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

FG.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值