Wooden Sticks

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:(有一堆n根木棍。每根棍子的长度和重量都是事先知道的。这些木棒将由木工机械一根一根地加工。机器准备加工一根棍子需要一些时间,称为准备时间。设置时间与机器中的清洁操作以及更换工具和形状相关。木工机械的安装时间如下:)

(a) The setup time for the first wooden stick is 1 minute.((a)第一根木棍的设置时间为1分钟。)
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.((b)在加工完长度为l、重量为w的棒料后,如果l<=l '和w<=w ',机器将不需要为长度为l '和重量为w '的棒料设置时间。否则,需要1分钟进行设置。)

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).(你要找到处理一堆n根木棒的最短准备时间。例如,如果您有五个棒,它们的长度和重量对是(4,9)、(5,2)、(2,1)、(3,5)和(1,4),那么最小设置时间应该是2分钟,因为有一系列对(1,4)、(3,5)、(4,9)、(2,1)、(5,2)。)

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.(投入;输入由测试用例组成。测试用例的数量(T)在输入文件的第一行给出。每个测试用例由两行组成:第一行有一个整数n,1<=n<=5000,代表测试用例中木棒的数量,第二行包含n ^ 2个正整数l1,w1,l2,w2,…,ln,wn,每个数量级最多10000,其中li和wi分别是第I根木棍的长度和重量。2n个整数由一个或多个空格分隔。)

Output
The output should contain the minimum setup time in minutes, one per line.(输出;输出应包含最小设置时间(分钟),每行一个。)

Sample Input (输入)
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1

Sample Output (输出)
2
1
3

#include <iostream>
#include <algorithm>
using namespace std;

int temp[5050];

struct wood{
    int length;
    int weigh;
}woodarr[5050];

int compare(wood a,wood b) {
    if (a.length == b.length)
        return a.weigh < b.weigh;
    return a.length < b.length;

}

int main() {

    int T,N,j;
    int time;
    cin >> T;
    while (T--) { // T是测试实例的数量,T--是循环减少实例,值得全部循环完毕。
        cin >> N;   // N 是此组测试实例的数量,T N 相同,但表示的内容不同,目的是容易区分。
        for (int i = 0; i < N; i++)
            cin >> woodarr[i].length >> woodarr[i].weigh;
        sort(woodarr+0, woodarr + N, compare);


        time = 1;
        temp[0] = woodarr[0].weigh;
        for (int i = 1; i < N; i++)
        {
            for (j = 0; j < time; j++) {
                if (woodarr[i].weigh >= temp[j]) {
                    temp[j] = woodarr[0].weigh;
                    break; // 排序。
                }
            }
            if (j == time) {
                if (woodarr[i].weigh < temp[j - 1]) {
                    temp[j] = woodarr[i].weigh;
                    time++;  // 替换大的数。
                }
            }
        }
        cout << " " << time << endl;
    }

    cout << "Hello, World!" << std::endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值