【PAT(甲级)】1010 Radix 测试点的分析

本文介绍了一种利用二分查找算法解决特定进制转换问题的方法,即给定两个不同进制的正整数,寻找合适的进制使二者数值相等。文章详细解释了解题思路,并提供了一个具体的C++实现示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1​ and N2​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

解题思路:

按照要求,将N1或者N2先转换成十进制数,然后再求出进制转换的上下限,通过二分查找来找到最小的那个符合题意的进制使得N1==N2。

进制的下限很明显就是N1或N2字符串里面最大的那一个数字加一(不然的话就不符合进制转换的定义了,例如2进制的数里面最大是1)。进制转换的上限就是先前你转换成十进制的数字加一,打个比方,你将N1转换成10进制后是12345,N2最小是个位数,只能在进制12346时可能满足N1==N2。

易错点:

1. 测试点0是N1,N2相同的时候,需要找到最小的进制使得答案满足。

2.定义的时候应该定义成long long int,因为它的进制可能很大很大,radix也可能很大很大。

3.因为题目里面的答案是包括在long long int里面的,但是当你通过进制转换的过程当中,可能会出现超过规定范围的情况,例如’aaaaa‘ 在12345678进制的时候,转换成十进制就会变成负数。这个时候你需要默认它大于实际值,直接并入大于那一种情况处理就行。

//详细情况可以看代码注释

代码:

#include<bits/stdc++.h>
using namespace std;

string N1,N2;
int tag;
long long int radix,ten_N1,ten_N2;
long long int result=1;
int flag=0;

long long int turn_ten(string a,long long int b){//转换成10进制的数字 
	long long int sum=0;int k=0;
	for(int i=a.size()-1;i>=0;i--){
		if(a[i]>='0'&&a[i]<='9')
			sum+=(a[i]-'0')*pow(b,k++);
		else if(a[i]>='a'&&a[i]<='z')
			sum+=(a[i]-'a'+10)*pow(b,k++);
	}
	return sum;
}

int return_l(string a){//求出下界,就是字符串内最大的数+1 
	int b=0;
	for(int i=0;i<a.size();i++){
		int temp=0;
		if(a[i]>='a'&&a[i]<='z') temp=a[i]-'a'+10;
		else temp=a[i]-'0';
		if(temp>b) b=temp;
	}
	return b;
}


int main(){
	cin>>N1>>N2>>tag>>radix;
	if(tag==1){//tag==1时的处理 
		ten_N1 = turn_ten(N1,radix);
		long long int r = ten_N1+1;
		int l = return_l(N2)+1;
		while(l<=r){ 
			long long int mid=(l+r)/2;
			if(turn_ten(N2,mid)==ten_N1){//当他们相等的时候就把值赋值给result 
				result=mid; 
				r=mid-1;//需要找到最小的,所以r还需要往左移动继续找
				flag=1;
			}
			else if(turn_ten(N2,mid)>ten_N1||turn_ten(N2,mid)<0){
				//当大于,或者答案小于0时,右界往左移动 
				r=mid-1;
			}
			else if(turn_ten(N2,mid)<ten_N1){
				//当小于时,左界往右移动 
				l=mid+1;
			}	
		}
	}
	else if(tag==2){//tag==2时的处理,与1相似 
		ten_N2 = turn_ten(N2,radix);
		long long int r = ten_N2+1;
		int l = return_l(N1)+1;
		while(l<=r){
			long long int mid=(l+r)/2;
			if(turn_ten(N1,mid)==ten_N2){
				result=mid;
				r=mid-1;
				flag=1;
			}
			else if(turn_ten(N1,mid)>ten_N2||turn_ten(N1,mid)<0){
				r=mid-1;
			}
			else if(turn_ten(N1,mid)<ten_N2){
				l=mid+1;
			}	
		}
	}
	if(flag) cout<<result;
	else cout<<"Impossible";
	return 0;
}

### 关于1010 Radix测试点的技术含义及用途 对于特定标记为“1010 Radix”的测试点,在计算机科学领域内通常涉及的是基数(Radix)的概念,这主要关联到数据表示形式以及算法设计中的数制转换。然而,“1010”作为一个二进制字符串可以直接被解释为十进制下的数值10;当提到“1010 Radix”,可能是指基于不同进制间相互转化的一种测试案例。 #### 基数概念解析 在信息技术里,基数指的是某个计数系统的底数或基础。例如: - **二进制** (Binary): 使用0和1两个符号,其基数为2; - **八进制** (Octal): 使用0至7八个符号,基数为8; - **十进制** (Decimal): 日常生活中常用的数字系统,使用0到9十个符号,基数为10; - **十六进制** (Hexadecimal): 计算机编程中常用,除了0-9外还加入了A-F六个字母作为额外的记号,因此基数为16。 针对“1010 Radix”这一表述,如果将其视为一个特殊的测试场景,则可能是为了验证程序能否正确处理来自多种进制的数据输入,并确保这些数据能够在不同的基数之间准确无误地互相转换[^1]。 #### 实际应用场景举例 考虑如下Python代码片段用于展示如何实现简单的多进制间的转换功能: ```python def convert_base(number_str, from_radix=10, to_radix=10): """Convert a string representing an integer in one base to another.""" decimal_value = int(number_str, from_radix) result = '' while decimal_value > 0: remainder = decimal_value % to_radix if remainder >= 10: # Convert numbers above 9 into corresponding letters A-Z. char = chr(ord('A') + remainder - 10) else: char = str(remainder) result = char + result decimal_value //= to_radix return '0' if not result else result print(convert_base('1010', 2, 10)) # Output should be "10" ``` 此函数`convert_base()`可以接收三个参数:待转换的原始数值串、源基数(`from_radix`)以及目标基数(`to_radix`)。通过调用内置的`int()`函数先将给定的字符串按照指定的原生基数转成内部统一使用的十进制整型值,之后再依据目的基数逐步构建新的表达方式直至完成整个过程。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值